Closed Bug 1524209 Opened 3 years ago Closed 3 years ago

2.8 - 2.9% tp5n main_startup_fileio (windows7-32) regression on push b5ac6baec29b55e5270c7c2abc9ddc446907144b (Wed Jan 30 2019)

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Bebe, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=b5ac6baec29b55e5270c7c2abc9ddc446907144b

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

3% tp5n main_startup_fileio windows7-32 opt e10s stylo 88,761,893.33 -> 91,334,012.00
3% tp5n main_startup_fileio windows7-32 pgo e10s stylo 94,762,108.17 -> 97,418,048.00

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=19038

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling

Blocks: 1475564, 1521698
Component: General → Audio/Video: Playback
Product: Testing → Core
Version: Version 3 → unspecified
Duplicate of this bug: 1523959

What is talos testing here?

If this is based on the size of the binary, it's the same as Bug 1523959, and should be closed as WONTFIX

AV1 was enabled on windows 32, of course the code is going to be slightly bigger. same resolution as what was done for bug
1523959

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX

(In reply to Jean-Yves Avenard [:jya] from comment #2)

What is talos testing here?

If this is based on the size of the binary, it's the same as Bug 1523959, and should be closed as WONTFIX.

:aklotz can you confirm :jya's assumption?

Flags: needinfo?(aklotz)

(In reply to Jean-Yves Avenard [:jya] from comment #2)

What is talos testing here?

Talos is testing the total amount of main thread I/O from process start to the session store window restored event.

Flags: needinfo?(aklotz)
You need to log in before you can comment on or make changes to this bug.