Closed Bug 1524210 Opened 9 months ago Closed 9 months ago

Clicking near the about:preferences navigation menu deselects the previously selected menu item

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified

People

(Reporter: emilghitta, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image issue.gif

Affected versions

  • Firefox 67.0a1 (BuildId:20190130215539).
  • Firefox 66.0b3 (BuildId:20190128143734).

Unaffected versions

  • Firefox 65.0 (BuildId:20190124174741).
  • Firefox 60.5.0esr (BuildId:20190124141046).

Affected platforms

  • Windows 10 64bit.
  • macOS 10.11
  • Ubuntu 16.04 64bit.

Steps to reproduce

  1. Launch Firefox.
  2. Access the about:preferences page.
  3. Click on any button from the about:preferences navigation menu (ex: Search).
  4. Click on the empty space near the about:preferences navigation menu.

Expected result

  • The selected button from step 3 remains selected and has a blue color.

Actual result

  • The button gets deselected.

Regression range

Additional notes

  • For further information regarding this issue, please observe the attached screencast.

Hi Paolo,

It seems that mozregression points out Bug 1472557 for causing this regression.

Can you please have a look?

Thank you.

Flags: needinfo?(paolo.mozmail)

[Tracking Requested - why for this release]:

User-visible regression that hasn't yet been released -> P1. Might also affect other richlistboxes.

We should be able to distinguish which category is selected at all times, so I don't think this is a 'trivial' regression. To be fair, this seems to only happen when clicking inside the richlistbox and outside of a richlistitem, so it's not like this will happen to every about:preferences user all of the time...

Jared/Brian, I think Paolo is on PTO this week, do either of you have cycles to pick this up? I should hope the fix would be fairly straightforward.

Severity: trivial → normal
Flags: needinfo?(jaws)
Flags: needinfo?(bgrinstead)
Priority: -- → P1
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(jaws)
Flags: needinfo?(bgrinstead)

There are a couple ways to fix this specific bug in Preferences. We could expand the padding up to the start border and remove the margin, though there would still exist a 1px padding on the richlistbox. Historically this code, at least for Preferences, was impossible to hit. The scrollbox couldn't get clicked because its size was defined by an inner xul:box that was the size of the richlistitems and whatever margin they had. Clicking next to the richlistitems in the Preferences before this regression was a click on the anonymous box and thus didn't clear the selection. Another potential fix could be if we added a special attribute that doesn't allow deselecting if clicking into nothing, but that seems like a band-aid that we would end up using in many other places instead of just removing this behavior.

Attachment #9040782 - Attachment description: Bug 1524210 - Remove the event handler on richlistbox that clears the selection when the box itself is clicked. r?Gijs → Bug 1524210 - Only clear the richlistbox selection when the box itself is clicked if the richlistbox is of multiselection type. r?Gijs
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3265cb8f1333
Only clear the richlistbox selection when the box itself is clicked if the richlistbox is of multiselection type. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

This issue is verified fixed using Firefox 67.0a1 (BuildId:20190206215551) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 18.04 64bit.

Status: RESOLVED → VERIFIED

Can you request uplift to beta? This seems straightforward and we have a chance to fix the regression before shipping to release.

Flags: needinfo?(jaws)

Comment on attachment 9040782 [details]
Bug 1524210 - Only clear the richlistbox selection when the box itself is clicked if the richlistbox is of multiselection type. r?Gijs

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1472557

User impact if declined

Users may be able to "unselect" the category they are viewing in preferences. No functional issues will come from this but it may look awkward to the user.

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

No

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

This patch allows for clearing of selection only on multiselect boxes, which are the only type within Firefox that make sense to unselect a choice.

String changes made/needed

None

Flags: needinfo?(jaws)
Attachment #9040782 - Flags: approval-mozilla-beta?

Comment on attachment 9040782 [details]
Bug 1524210 - Only clear the richlistbox selection when the box itself is clicked if the richlistbox is of multiselection type. r?Gijs

Fix for new regression, let's uplift for beta 7.

Attachment #9040782 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This issue is verified fixed using Firefox 66.0b7 (BuildId:20190211185957) on Windows 10 64bit, macOS 10.13.6 and Ubuntu 18.04 64bit.

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: in-qa-testsuite?(oana.botisan)
Flags: in-qa-testsuite?(oana.botisan) → in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.