Closed Bug 1524261 Opened 2 years ago Closed 2 years ago

Whatsapp emoji list isn't correctly clipped

Categories

(Core :: Graphics: WebRender, defect, P2)

67 Branch
Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed
firefox67 --- fixed

People

(Reporter: Tobias.Marty, Assigned: kats)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Updated Nightly to 67.0a1 (2019-01-31) (64-bit).
Opened emoji list in Whatsapp Web chat window.

Actual results:

When scrolling in the emoji list the emojis go "out of bounds" of their designated window area and overlay the chat.

https://abload.de/img/unbenannt28j0c.png

Blocks: 1523776
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kats)
Summary: Whatsapp → Whatsapp emoji list isn't correctly clipped
Keywords: regression
OS: Unspecified → All
Priority: -- → P2
Assignee: nobody → kats
Attached video 2019-01-31 15-13-08.mp4
Attached patch WIPSplinter Review

Looks like the emojis are inside a transform (possibly multiple nested transforms) and the clip chain isn't getting applied properly on the stacking contexts for the transforms. Attached WIP fixes it, but I dunno if it breaks other stuff.

Flags: needinfo?(kats)

Bunch of orange, but they all look like fuzzable differences. On Linux at least. So that's good news.

On Mac and Windows the differences are also fuzzable but there's a lot more due to text antialiasing differences. Fixing this up is going to be quite tedious. For now I'll back out the regressing changes.

No longer blocks: 1524303
Duplicate of this bug: 1524303

WhatsApp Web has emojis in divs with border-radius, inside a transform,
inside a scrollframe. The patch in bug 1523776 broke the clipping in
that scrolling the scrollframe would make the emoji visible outside the
scrollframe. This reftest replicates that scenario.

Duplicate of this bug: 1524381
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b67d5ecb31b3
Add a reftest to prevent regression. r=jrmuizel

This one is only failing on linux32 debug where we're still running non-e10s tests (i.e. this needs a skip-if(!asyncPan))

Flags: needinfo?(kats)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/441cc27a02fa
Add a reftest to prevent regression. r=jrmuizel
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Would like to uplift this, a=test-only

Kats are you still intending uplift here?

Flags: needinfo?(kats)

Yup, I'll do that now.

Flags: needinfo?(kats)
You need to log in before you can comment on or make changes to this bug.