Closed Bug 1524292 Opened 7 months ago Closed 7 months ago

Unable to find whatsapp web emoji spans in the DOM inspector

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1524005

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

Go to web.whatsapp.com, use the 2d barcode thingy (assuming you have WhatsApp on your phone) to get in. Go to a chat, and open the emoji panel. Use the devtools element picker to try and find one of the emoji elements. While highlighting the emoji, the overlay says something like span.b61.emojik.wa but clicking on it doesn't find it in the DOM.

I manually expanded the DOM nodes until I got to the place where it should be (inside one of <div class="Xof-g"> elements) but the span elements are still not in the inspector. I can also verify that the span's parentElement property points to the correct div, but it just doesn't show up in the inspector and I don't know why.

This might be a duplicate of bug 1524005. Kartikaya: can you confirm that this happens on nightly, and is very recent?

Flags: needinfo?(kats)

I don't know if it's a recent regression, but I was seeing this on today's Nightly, yes.

Flags: needinfo?(kats)

Also FWIW I saved the page locally and used the saved version, which seems to have the spans in the right places.

Ok thanks Kats. I do think this is a duplicate of that bug. I tried to reproduce, and the problem seems to show in somewhat different ways than that bug, but I'm willing to bet that it's still a dupe. Too many things in common.
So I'll close it for now, and if it still doesn't work in tomorrow's nightly, then let's re-open it.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1524005
You need to log in before you can comment on or make changes to this bug.