Closed Bug 1524330 Opened 8 months ago Closed 8 months ago

wpt windows close when running with --pause-after-test

Categories

(Testing :: web-platform-tests, defect)

Version 3
defect
Not set

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: jgraham, Assigned: jgraham)

Details

Attachments

(1 file)

This is a regression from Bug 1519862, which tried to close winodws after the end of tests rather than before the next tests, to help with shutdown crashes. It's a little tricky to fix this in a good way so the easiest thing might be to try reverting the previous patch and see if it causes extra instability.

Reverts the change from bug 1519862 to make wptrunner close the
windows after the test is finished, since this breaks
--pause-after-test and getting both behaviours to work together is a
little tricky given the idea is to close before setting the test
result, but --pause-on-unexpected requires that we have the test open
after the result is known.

Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/c39fd15ce2df
Make wpt pause with --pause-after-test, r=ato
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.