Closed Bug 1524429 Opened 7 months ago Closed 5 months ago

Move build/autoconf/arch.m4 to python configure

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

No description provided.

It hasn't needed it since bug 1397776.

The file is essentially limited to ARM flag tweaks, so we make the
corresponding python configure code ARM-only. In large parts, the
python code sets things up similarly, although in a few places we try to
be smarter about than the current autoconf-based code.

The resulting config.status have been verified to only have
insignificant differences on both arm and aarch64 android builds.

Depends on D24000

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/1a5a5aef01d5
MOZ_ANDROID_CPU_ARCH doesn't need MOZ_ARCH. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/7947b90f1580
Move build/autoconf/arch.m4 to python configure. r=nalexander

Fun times. This didn't fail when I ran the lint locally... but that was before I added the when on the include('arm.configure')... and sure enough, I can reproduce locally now, and if I remove the when, I'm back to the lint passing. It was kind of unexpected, actually, that the lint passed in the first place. I was happy that it did, because that avoided having to figure out a way around the lint... but I guess I'll have to figure it out in the end.

Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/22c1c1ddce35
MOZ_ANDROID_CPU_ARCH doesn't need MOZ_ARCH. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/afac9aaedb23
Move build/autoconf/arch.m4 to python configure. r=nalexander
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.