Mozilla crashed when this page loaded.

RESOLVED WORKSFORME

Status

()

Core
Layout
P2
critical
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: masayuki, Assigned: Marc Attinasi)

Tracking

({crash, stackwanted, testcase})

Trunk
x86
All
crash, stackwanted, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB7449270K, TB7440849K, URL)

Attachments

(1 attachment)

If you go to http://www5d.biglobe.ne.jp/~iiaccess/index.html,
Mozilla will crash.
Reproduced on 2002061712-trunk/WinXP.

Talkback ID
TB7440849K
TB7440814X

Updated

16 years ago
Keywords: crash, stackwanted

Comment 1

16 years ago
works for me, but...

the page is framed based, with an invisible frame and a big frame. the url of
the big frame is:
   http://cgi.www5d.biglobe.ne.jp/~iiaccess/cgi-bin/main.cgi

the url you posted probably doesn't really points to the page that crashed your
browser

Comment 2

16 years ago
Created attachment 88058 [details]
HTML page pared down to the minimum code that causes crash.

Comment 3

16 years ago
Confirmed in buikd 2002061712, PC Win98.  This crash is being caused by invalid
HTML in the main.cgi frame.  The page has a FORM tag immediately after a TBODY.
 Removing the TBODY tags allows the page to load.

Crash data:
MOZILLA caused an invalid page fault in
module GKLAYOUT.DLL at 0187:6072fd9f.
Registers:
EAX=0064b57c CS=0187 EIP=6072fd9f EFLGS=00010202
EBX=02f9f344 SS=018f ESP=0064b2c4 EBP=0064b2d0
ECX=02f9f4c8 DS=018f ESI=00000000 FS=259f
EDX=01eedb00 ES=018f EDI=0064b2f4 GS=0000
Bytes at CS:EIP:
83 26 00 51 ff 70 04 e8 04 67 ff ff 83 c4 10 85 
Stack dump:
02f9f344 0064b2e4 02f9f4dc 0064b364 6075dd3a 0064b57c 0064b4b8 02f9f344 00000000
00000000 00000000 00000000 00000000 00000000 00000000 00000000 

Comment 4

16 years ago
Confirming crash using same build on W2K -> TB7449270K.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Whiteboard: TB7449270K, TB7440849K

Updated

16 years ago
QA Contact: petersen → moied

Updated

16 years ago
Priority: -- → P2
I can't reproduce on 2002061908-trunk/WinXP.
WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

9 years ago
Crashtest added as part of http://hg.mozilla.org/mozilla-central/rev/afc662d52ab1
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.