Thunderbird-60.5.0-build2-bz2 is missing info from toplevel submission

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: nthomas, Assigned: rjl)

Tracking

Thunderbird 67.0

Thunderbird Tracking Flags

(thunderbird_esr6066+ fixed, thunderbird66 fixed, thunderbird67 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

.. which means any Thunderbird user < 60.0 isn't offered 60.5.0, and we get a bunch of errors in Sentry.

The diff on the initial submit is only

--- Data Version 
+++ Data Version 1
@@ -0,0 +1,5 @@
+{
+  "hashFunction": "sha512",
+  "name": "Thunderbird-60.5.0-build2-bz2",
+  "schema_version": 9
+}

at the same time as the win32 en-US build is submitted, so that's probably automated release blob creation. So I think we're missing the submit-toplevel task which should come from https://hg.mozilla.org/releases/comm-esr60/file/tip/taskcluster/ci/release-balrog-submit-toplevel/kind.yml#l66.

This must be a dupe, because the last change to the previous release (Thunderbird-60.4.0-build2-bz2) is fixing the same problem. It does:

--- Data Version 292
+++ Data Version 293
@@ -16,7 +16,18 @@
   "hashFunction": "sha512",
   "name": "Thunderbird-60.4.0-build2-bz2",
   "platforms": {
+    "Darwin_x86-gcc3": {
+      "alias": "Darwin_x86_64-gcc3-u-i386-x86_64"
+    },
+    "Darwin_x86-gcc3-u-i386-x86_64": {
+      "alias": "Darwin_x86_64-gcc3-u-i386-x86_64"
+    },
+    "Darwin_x86_64-gcc3": {
+      "alias": "Darwin_x86_64-gcc3-u-i386-x86_64"
+    },
     "Darwin_x86_64-gcc3-u-i386-x86_64": {
+      "OS_BOUNCER": "osx",
+      "OS_FTP": "mac",
       "locales": {
         "ar": {
           "appVersion": "60.4.0",
@@ -717,6 +728,8 @@
       }
     },
     "Linux_x86-gcc3": {
+      "OS_BOUNCER": "linux",
+      "OS_FTP": "linux-i686",
       "locales": {
         "ar": {
           "appVersion": "60.4.0",
@@ -1417,6 +1430,8 @@
       }
     },
     "Linux_x86_64-gcc3": {
+      "OS_BOUNCER": "linux64",
+      "OS_FTP": "linux-x86_64",
       "locales": {
         "ar": {
           "appVersion": "60.4.0",
@@ -2117,6 +2132,8 @@
       }
     },
     "WINNT_x86-msvc": {
+      "OS_BOUNCER": "win",
+      "OS_FTP": "win32",
       "locales": {
         "ar": {
           "appVersion": "60.4.0",
@@ -2816,7 +2833,15 @@
         }
       }
     },
+    "WINNT_x86-msvc-x64": {
+      "alias": "WINNT_x86-msvc"
+    },
+    "WINNT_x86-msvc-x86": {
+      "alias": "WINNT_x86-msvc"
+    },
     "WINNT_x86_64-msvc": {
+      "OS_BOUNCER": "win64",
+      "OS_FTP": "win64",
       "locales": {
         "ar": {
           "appVersion": "60.4.0",
@@ -3515,6 +3540,9 @@
           "displayVersion": "60.4.0"
         }
       }
+    },
+    "WINNT_x86_64-msvc-x64": {
+      "alias": "WINNT_x86_64-msvc"
     }
   },
   "schema_version": 9

rjl, could you fix this up please.

Flags: needinfo?(rob)

Possibly the Thunderbird QA process isn't checking updates from < 60.0 are working on the test channels ?

The underlying problem seems to be that release_type is '' in promote decision task - https://taskcluster-artifacts.net/f7FzjhA9TlCwrtaXCPgNqw/0/public/parameters.yml. The bz2 toplevel task is expecting to get 'esr60', while PER_PROJECT_PARAMETERS wants to set 'release'. Something may have been missed when https://hg.mozilla.org/releases/comm-esr60/rev/440a81faa54e landed.

(Assignee)

Comment 5

3 months ago

Thanks Nick, I noticed something was up the other day during the release and made a note to look into it. I didn't realize it was causing you folks issues. I'll re-prioritize.

Assignee: nobody → rob
Flags: needinfo?(rob)
(Assignee)

Comment 6

3 months ago

I updated the Balrog release. It still needs a tb-relman signoff, so I'm adding Wayne to needinfo+. I'll followup with an email as well.

Flags: needinfo?(vseerror)

Updated

3 months ago
Flags: needinfo?(vseerror)
(Assignee)

Updated

3 months ago
Component: Release Automation: Updates → Build Config
Product: Release Engineering → Thunderbird
QA Contact: mtabara
Target Milestone: --- → Thunderbird 60.0
Version: unspecified → 60
(Assignee)

Comment 7

3 months ago

Untested, submitting for feedback. Thanks nthomas@mozilla.com for helping track this down.

Attachment #9040938 - Flags: feedback?(nthomas)
Comment on attachment 9040938 [details] [diff] [review]
Update release type in release-balrog tasks for TB esr60

Looks good to me based on the parameters given to task I_jBXKGFRjaQK7ce9I3XpA, which I meant to link to in comment #3 rather than an older release.
Attachment #9040938 - Flags: feedback?(nthomas) → feedback+

(In reply to Rob Lemley [:rjl] from comment #6)

I updated the Balrog release. It still needs a tb-relman signoff, so I'm adding Wayne to needinfo+. I'll followup with an email as well.

Unfortunately this wasn't enough to quench the errors; my diff at comment #2 was incomplete (eg doesn't include fileUrls). I've scheduled another update to Thunderbird-60.5.0-build2-bz2 to fix it up, please see the diff at https://aus4-admin.mozilla.org/releases/scheduled_changes. It also adds the updateLine config which makes the Details link point to the release notes.

Flags: needinfo?(vseerror)
Flags: needinfo?(rob)

Thanks. Signed off rel-man

Flags: needinfo?(vseerror)
(Assignee)

Comment 11

3 months ago

Thanks Nick!

Flags: needinfo?(rob)
(Assignee)

Updated

3 months ago
Status: NEW → ASSIGNED

We're no longer getting any errors, the last was at Feb 4, 2019 12:13:34 PM UTC.

(Assignee)

Comment 13

3 months ago

[COMM-BETA Approval Request Comment]
Regression caused by (bug #): 1490094
User impact if declined: Automatic updates to current versions fail for users running TB < 60.0
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
Low risk. Worst case scenario is it doesn't work and users will not be able to update. We can remediate such a situation though.

This issue affects comm-esr60 specifically as it is the only release where the old bz2 update mars are generated. Requesting beta uplift for completeness.

[COMM-ESR60 Approval Request Comment]
Regression caused by (bug #): 1490094
User impact if declined: Automatic updates to current versions fail for users running TB < 60.0
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
Low risk. Worst case scenario is it doesn't work and users will not be able to update. We can remediate such a situation though.

This issue affects comm-esr60 specifically as it is the only release where the old bz2 update mars are generated. Requesting beta uplift for completeness.

Attachment #9040938 - Attachment is obsolete: true
Attachment #9041268 - Flags: review?(geoff)
Attachment #9041268 - Flags: approval-comm-esr60?
Attachment #9041268 - Flags: approval-comm-beta?
Attachment #9041268 - Flags: review?(geoff) → review+
(Assignee)

Updated

3 months ago
Target Milestone: Thunderbird 60.0 → Thunderbird 67.0

Comment 14

3 months ago

Looks like we should land this one day ;-)

Keywords: checkin-needed

Updated

3 months ago
Attachment #9041268 - Flags: approval-comm-esr60?
Attachment #9041268 - Flags: approval-comm-esr60+
Attachment #9041268 - Flags: approval-comm-beta?
Attachment #9041268 - Flags: approval-comm-beta+

Comment 15

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/eb7f4d40bfd6
Fix incorrect release types in release-balrog-* kind.yml files. r=darktrojan

Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 16

3 months ago

TB 66 beta:
https://hg.mozilla.org/releases/comm-beta/rev/a7c0ece1f227

I don't need ESR tracking since the bug is fixed and it's just a matter of uplifting the change.

Looking at the commit comments,
https://searchfox.org/mozilla-central/source/taskcluster/taskgraph/decision.py#93.
should never be used. Search results without permalink are useless.

You need to log in before you can comment on or make changes to this bug.