Closed Bug 1524496 Opened 10 months ago Closed 9 months ago

Intermittent toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess.js | PO_observe - [PO_observe : 4040] the application process exit value should be 0 - -1 == 0

Categories

(Toolkit :: Application Update, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rstrong)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [retriggered])

#[markdown(off)]
Filed by: archaeopteryx [at] coole-files.de

http://localhost:5000/logviewer.html#?job_id=225397319&repo=autoland

https://queue.taskcluster.net/v1/task/buiN6z-nTI6PRrT17kj4Mw/runs/0/artifacts/public/logs/live_backing.log

[task 2019-02-01T08:18:34.111Z] 08:18:34 INFO - TEST-PASS | toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess.js | getLaunchBin - [getLaunchBin : 2572] the file or directory should exist, path: /bin/sh - true == true
[task 2019-02-01T08:18:34.112Z] 08:18:34 INFO - "08:18:33:182 | TEST-INFO | ../data/xpcshellUtilsAUS.js | [getProcessArgs : 3872] created /builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess_launch.sh containing:
[task 2019-02-01T08:18:34.113Z] 08:18:34 INFO - #! /bin/sh
[task 2019-02-01T08:18:34.115Z] 08:18:34 INFO - /builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess/dir.app/firefox-bin -no-remote -test-process-updates > /dev/null 2>&1"
[task 2019-02-01T08:18:34.117Z] 08:18:34 INFO - "08:18:33:182 | TEST-INFO | ../data/xpcshellUtilsAUS.js | [runUpdateUsingApp : 4107] launching /bin/sh /builds/worker/workspace/build/tests/xpcshell/tests/toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess_launch.sh"
[task 2019-02-01T08:18:34.118Z] 08:18:34 INFO - "08:18:33:183 | TEST-INFO | ../data/xpcshellUtilsAUS.js | [runUpdateUsingApp : 4118] launching application"
[task 2019-02-01T08:18:34.119Z] 08:18:34 INFO - "08:18:33:184 | TEST-INFO | ../data/xpcshellUtilsAUS.js | [runUpdateUsingApp : 4121] finish - launching application to apply update"
[task 2019-02-01T08:18:34.121Z] 08:18:34 INFO - (xpcshell/head.js) | test stageUpdateFinished finished (2)
[task 2019-02-01T08:18:34.123Z] 08:18:34 INFO - "08:18:33:356 | TEST-INFO | ../data/xpcshellUtilsAUS.js | [PO_observe : 4033] topic: process-failed, process exitValue: -1"
[task 2019-02-01T08:18:34.125Z] 08:18:34 WARNING - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/unit_base_updater/marAppApplyUpdateStageSuccess.js | PO_observe - [PO_observe : 4040] the application process exit value should be 0 - -1 == 0

Backout by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a2168937e103
Backed out changeset 2fc5715105a2 due to bug 1524496. r=me

This should be fixed with bug 1524366 backed out.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(robert.strong.bugs)
Resolution: --- → FIXED
Assignee: nobody → robert.strong.bugs
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.