Closed Bug 1524532 Opened 2 years ago Closed 1 year ago

[remote-dbg-next] User can still open devtools on about:devtools-toolbox

Categories

(DevTools :: about:debugging, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jdescottes, Unassigned)

References

(Blocks 1 open bug)

Details

Follow up to Bug 1495944, there is still a way for users to open DevTools on about:devtools-toolbox

The STRs have to be followed very accurately to reproduce it

STRs:

  • start firefox
  • go to about:debugging
  • debug/inspect a tab
  • in the about:devtools-toolbox that was opened, select Tools > WebDeveloper

ER: The toolbox menu items should not be displayed
AR: The toolbox menu items are displayed (for instance Toggle Tools). Using them will open a nested devtools toolbox.

Note: if you open the Tools > WebDeveloper menu at any time before doing it in about:devtools-toolbox, the menu will be correct. It needs to be the first opening of the menu.

Priority: -- → P3

Hi @Julian, I've tested the issue in latest Beta 69.0b7 => should we consider that this issue is fixed? because in my end the toggle tools won't appear and the toolbox renders in a normal behavior.

Flags: needinfo?(jdescottes)

Thanks for the heads up Liviu!

Indeed this bug is no longer valid. We now allow to use the devtools menu, it simply interacts with about:devtools-toolbox instead of opening a nested toolbox.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jdescottes)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.