Closed Bug 1524706 Opened 2 years ago Closed 2 years ago

ReferenceError: nsSimpleEnumerator is not defined[Learn More] jsProtoHelper.jsm:877:5

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 67.0

People

(Reporter: Paenglab, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file)

When I open the chat properties in Account Manager I get this errors:

ReferenceError: nsSimpleEnumerator is not defined[Learn More] jsProtoHelper.jsm:877:5
00:00:57.873
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "nsSimpleEnumerator is not defined" {file: "resource:///modules/jsProtoHelper.jsm" line: 877}]'[JavaScript Error: "nsSimpleEnumerator is not defined" {file: "resource:///modules/jsProtoHelper.jsm" line: 877}]' when calling method: [prplIProtocol::getOptions] am-im.js:62

Also when connecting to IRC, the auto-join Channels aren't joined.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9041895 - Flags: review?(richard.marti)
Keywords: regression
Comment on attachment 9041895 [details] [diff] [review]
bug1525360_nsSimpleEnumerator_not_defined.patch

This fixes the Account Manager issue. Thanks.
Attachment #9041895 - Flags: review?(richard.marti) → review+

(In reply to Richard Marti (:Paenglab) from comment #2)

Comment on attachment 9041895 [details] [diff] [review]
bug1525360_nsSimpleEnumerator_not_defined.patch

This fixes the Account Manager issue. Thanks.

The account manager issue I see is due to missing setTimeout/clearTimeout declarations at https://searchfox.org/comm-central/rev/25813ba6567fc17b19a236a6b9592c43e3b51146/chat/components/src/imAccounts.js#4-9

More work in bug 1525695.

Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/80c05e7d0121
fix "ReferenceError: nsSimpleEnumerator is not defined" in chat's jsProtoHelper.jsm. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 67.0
Blocks: 1520643
You need to log in before you can comment on or make changes to this bug.