Closed Bug 1524779 Opened 9 months ago Closed 8 months ago

Use a separate ghosted button to show all preferences

Categories

(Toolkit :: Preferences, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: Paolo, Assigned: Paolo)

References

(Blocks 1 open bug)

Details

(Keywords: access, ux-efficiency)

Attachments

(1 file, 2 obsolete files)

A separate "Show All" button would allow for mouse-only interaction in the rare cases where this could be needed, and the placeholder text could be updated to "Search or add" to make "add" more discoverable.

This would also make it easier to set a minimum number of characters to type before search results are shown, to limit the maximum amount of rows for the more common use cases.

Duplicate of this bug: 1523954

My recommendations:

  • "Show All" button - when pressed it will do same work as pressing ESC keyboard button, it could hide itself after showing all
  • "New" button - when pressed it will show dropdown menu with 3 items: "String", "Integer", "Boolean"

Attaching some mockups done in Paint.

Comment on attachment 9041012 [details]
Show All or ESC not pressed + New.png

This mockup is a bit misleading because the link will be probably be inconspicuous, less visible than a button, because while it's a use case we can support, it is not the primary use case and using it has performance issues.
Attachment #9041012 - Attachment is obsolete: true
Comment on attachment 9041013 [details]
Show All or ESC pressed + New.png

And for "new", a dropdown is out of scope for this bug and WONTFIX for the moment, because of cost and because it goes in a different direction than the desired final design. It may become an independent button, but we have no plans to do it for the moment.
Attachment #9041013 - Attachment is obsolete: true
Summary: Consider using a separate button for showing all preferences → Consider using a separate text link for showing all preferences

It's kinda odd for me that adding 2 simple buttons could cause any performance issues and about design it can always be changed for better accessibility, efficiency and discover purposes.

The performance issue is not the button, but the "show all" functionality. That is why Paolo wants to "hide" it a bit better.
Dropdowns are not design-able to be consistent with the photon guide, that is why we were trying to build the page without them.

Duplicate of this bug: 1525774

This allows interacting with the page without using the keyboard in the rare cases where this may be necessary. The separate button is ghosted and placed at the bottom of the page because search is the preferred interaction.

To improve performance, search is now activated automatically only after typing at least 3 characters. Pressing ESC allows resetting the input field without the performance impact of showing all preferences.

Summary: Consider using a separate text link for showing all preferences → Use a separate ghosted button to show all preferences
Attachment #9042498 - Attachment description: Bug 1524779 - Use a separate button to show all preferences. → Bug 1524779 - Use a separate button to show all preferences. r=mconley

This patch replaces the "Search or press ESC to show all" placeholder with a separate "Show All" button, and the placeholder becomes "Search or add". Mike thought the placeholder could say "Search or add preferences" for clarity, although I think it's a bit redundant given that this is the "about:config" page anyways. Amy, what do you think of these new strings?

Flags: needinfo?(amlee)
Duplicate of this bug: 1522961
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/329374773b81
Use a separate button to show all preferences. r=mconley,flod
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → paolo.mozmail

(In reply to :Paolo Amadini from comment #11)

This patch replaces the "Search or press ESC to show all" placeholder with a separate "Show All" button, and the placeholder becomes "Search or add". Mike thought the placeholder could say "Search or add preferences" for clarity, although I think it's a bit redundant given that this is the "about:config" page anyways. Amy, what do you think of these new strings?

I think it doesn't hurt to be clear and have "Search or add preferences". NI Meridel to approve strings.

Flags: needinfo?(amlee) → needinfo?(mwalkington)

I don't think "add preferences" is necessary and could be confusing.

I don't like the idea of just "Search preferences" because I'd like to distinguish between the about:config preferences versus the preferences users access from the hamburger menu.

I'm not a regular user of about:config. What kind of language do about:config users use when talking about modifying things in about:config? I am thinking something like "Search browser settings" or "Search configuration preferences" would distinguish this set of Preferences from the hamburger menu preferences, and be a bit more accurate.

Could someone on this bug enlighten me as to what language regular users of about:config use to describe the actions they take? Do they think of this as adjusting settings or preferences? and, are these browser settings/preferences or something else?

Flags: needinfo?(mwalkington) → needinfo?(paolo.mozmail)

The technical term used for "about:config" is "preferences", and it is the same on Windows, Mac, and Linux. The menu item that gives access to "about:preferences" is instead called "options" on Windows and "preferences" on other platforms.

The expressions "set a preference", "toggle a preference", or "pref flip" are common among regular "about:config" users. I don't think there is any chance of confusion between "about:config" and "about:preferences". That said, I'm comfortable with calling the textbox just "Search" and omitting the object altogether.

Flags: needinfo?(paolo.mozmail)

Thank you. Recommended strings:

Search field string: Search advanced preferences
Show all button string: Show All Preferences

Question: Does Escape still enable me to see all preferences? It no longer works for me but does work for a colleague of mine. If so, I would adjust copy.

Flags: needinfo?(paolo.mozmail)

No, the ESC key only clears the text box now, which goes back to the initial state.

Flags: needinfo?(paolo.mozmail)
QA Whiteboard: [qa-67b-p2]
You need to log in before you can comment on or make changes to this bug.