Closed Bug 1524799 Opened 2 years ago Closed 2 years ago

Page added to home screen opens a blank white page if FIrefox hasn't been active recently

Categories

(Firefox for Android :: General, defect)

Firefox 65
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1496684

People

(Reporter: namelessvoice, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

  1. Add a web app to the home screen via the "Add to home screen" option.
    (The particular site being used does not appear to matter.)
  2. Leave the phone idle for a while (unsure exactly how long, but probably for long enough for Android to suspend Firefox)
  3. Try to open the web app via the home screen shortcut

Actual results:

A pure white screen is displayed. There is no loading bar and the page does not load. It just stays white.

Expected results:

The web app page should load as expected.

Note that opening the main Firefox app will fix the issue.
e.g.
4. Once the white screen appears, go back to the home screen and start Firefox
5. Go back to the home screen and open the web app icon a second time, and it will now work.

I observed this behaviour on a Samsung Galaxy S5 SM-G900F, running LineageOS 15.1 (e.g. Android 8.1.0).
I've seen the issue many times in the last few months, across several LineageOS and Firefox for Android updates.

I believe that there was a point in the past when it worked as expected, but I can't remember for sure now.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496684
You need to log in before you can comment on or make changes to this bug.