Closed Bug 15249 Opened 20 years ago Closed 20 years ago

IMAP: Folder containing subfolders is not displayed/loaded

Categories

(MailNews Core :: Networking, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 7511

People

(Reporter: andreas.premstaller, Assigned: mscott)

Details

An IMAP folder containing 5 subfolders (and no messages in that level) is not
displayed. The subfolders themselves contain messages. "Normal" folders at the
root of the IMAP directory are loaded and displayed correctly.

prefs.js was edited by hand to:
user_pref("mail.server.server3.type", "imap");
user_pref("mail.server.server3.hostname", "mail1.uibk.ac.at");
user_pref("mail.server.server3.userName", "xxx");

The same problem occurred when the prefs were migrated with "apprunner
-installer".

Build: nightly 1999092909, and earlier ones
Platform: WinNT SP5 (German), 128MB RAM
Additional information: After migrating another 4.7 profile to Mozilla I
restarted Mozilla with my first profile and found Privat.sbd in the Messanger
folder listing ("Privat" being the name of the folder containing subfolders).
Clicking on it and entering the IMAP-password led to the following warning: "The
current command did not succeed. The mail server responded: nSELECT failed:
Can't ope mailbox Privat.sbd: no such mailbox". However the folder is here and I
see it using Netscape 4.x (or Pine).
QA Contact: lchiang → huang
In 4.x, are all your folders subscribed to?  See
http://bugzilla.mozilla.org/show_bug.cgi?id=7511
The parent folder as well as the child folders are all subscribed in 4.x. I
tried to delete mozregistry and user50 directories and migrate profile again
after verifying, it gives the same (negative) result.
Just a thought: I think it's not very intuitive for many-to-come "normal users"
not to migrate non-subscribed IMAP-folders that they see in 4.x
Target Milestone: M15
General case works for me. If there's some secondary problem, it can wait until
after B1.
Have you tried this recently? We've fixed a couple bugs in this area.
Right now I can't even access any of my IMAP folders (posted bug 23622).
Here is my .mailboxlist-File from the IMAP-Server:

INBOX
Computer
Main
Sent
Trash
NATWI-News
WWWAdmin
UIBK
Privat/
Privat/Menschen
Privat/Firmen
Privat/SciFi
Privat/Musik

Subfolders of Privat were never displayed with this file (actually recent builds
of Mozilla crashed, see Bug #23312, #23622).

I manually removed the slash from the line Privat/ and the subfolders and
their content were displayed nicely.

Here is the first line of my imap-log:
172[19afd30]: mail1.uibk.ac.at:NA:CreateNewLineFromSocket: * OK mail1.uibk.ac.at
IMAP4rev1 v12.258 server ready

So this is probably a mailserver-specific problem as well.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 7511 ***
Ops, I just saw, the folder "Privat" was subscribed all the time. But you said
2000-01-12 00:30, you can see the folders.
Feel free to reopen, if the problem still persists.
Status: RESOLVED → VERIFIED
Verified as duplicate of bug#7511
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.