Closed Bug 1524961 Opened 1 year ago Closed 1 year ago

[mozlog] Update MPL to latest version

Categories

(Testing :: Mozbase, enhancement, P3)

Version 3
enhancement

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: raphael, Assigned: pgadige__)

Details

Attachments

(4 files)

Currently mozlog is released under the MPL 1.1. Update the license to MPL 2.0 and publish a new release.

https://www.mozilla.org/en-US/MPL/

Priority: -- → P3

(In reply to Raphael Pierzina [:raphael] UTC+01:00 from comment #0)

I'm working on fixing this issue.

Currently mozlog is released under the MPL 1.1. Update the license to MPL 2.0 and publish a new release.

I suppose the license should be updated on mozlog's PyPI page as MPL 2.0
So I think I should modify its setup.py file located at https://hg.mozilla.org/mozilla-central/file/tip/testing/mozbase/mozlog/setup.py to reflect the new license.

I found a similar issue #1286557 was raised sometime ago. May I mark that one as duplicate of the current one?

Thank you!

Flags: needinfo?(rpierzina)

Updated the license for mozlog library by setting the new license number, MPL 2.0, in mozlog's setup.py file.

This patch updates mozlog license to MPL 2.0

Raphael and Geoff, I wonder if either of you could please review my patch and provide feedback.

Thank you!

Hey :pooja! Thank you for submitting a patch for this bug. I will have a look tomorrow!

Flags: needinfo?(rpierzina)
Assignee: nobody → poojagadige

Thank you, :raphael , for reviewing the change.

I've resolved the review comments as needed.

Please let me know if there is something amiss.

It's kinda strange that a new Differential Revision was created when I ran moz-phab after rewriting the commit message using hg amend -m.

Phabricator works by leaving an identifier in the commit message. When you run hg amend -m you overwrite the commit message with the new one, losing the identifier in the process. Then moz-phab doesn't see any revision to update so creates a new one.

In the future just use hg amend or hg commit --amend if you need to change the message.

Pushed by rpierzina@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/333566a1cbc8
Update mozlog's license to MPL 2.0. r=raphael
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.