Closed Bug 1525060 Opened 8 months ago Closed 5 months ago

Bottom rounded corners on macOS application window are boxy

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1375298

People

(Reporter: ato, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(4 files)

As can be seen from the attached screenshot, WebRender causes the
normally-rounded application corners on macOS to be boxy. It looks
like it tries to make the corners rounded, but the background
inherits the document’s background colour.

Is there a particular page that show this?

Flags: needinfo?(ato)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #1)

Is there a particular page that show this?

To me it is consistent across all documents. Sorry I wasn’t specific
about that earlier.

IIRC there was an attempt in WebRender to fix this? If so, this
may be a regression. In any case let me know if I can provide any
further information.

Flags: needinfo?(ato)

Here's what https://border-radius.com/ looks like for me on Mac. It looks correct to me. How does it look for you?

Flags: needinfo?(ato)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #3)

Here's what https://border-radius.com/ looks like for me on
Mac. It looks correct to me. How does it look for you?

Yes, I’m seeing the same as you with regards to
border-radius: 10px.

The problem is however not with CSS border-radius, but with
the bottom rounded corners of the application window
(i.e. ChromeWindow). I’m attaching another screenshot that
hopefully helps to illustrate this.

Flags: needinfo?(ato)
Summary: Rounded corners on macOS are boxy → Bottom rounded corners on macOS application window are boxy

If we zoom in very closely at the corner, it looks like there’s an
attempt at rounding the corner but that the background is not
transparent and instead inherits the same colour as the web document
background-color?

Ah. I think this is probably a dup.

Depends on: 1429522
Blocks: wr-mac
Priority: -- → P3

Dupe of bug #1375298 I guess.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1375298
You need to log in before you can comment on or make changes to this bug.