Port bug 1524358, Remove slugid and push comment from .taskcluster.yml

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
3 months ago
14 days ago

People

(Reporter: rjl, Assigned: rjl)

Tracking

Trunk
Thunderbird 67.0

Thunderbird Tracking Flags

(thunderbird_esr6066+ fixed, thunderbird66 fixed, thunderbird67 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

3 months ago

Port Bug 1524358 to C-C.
Stop relying on push comment, as_slugid from mozilla-taskcluster

Comment 1

3 months ago

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/f8e238ce124e
Port bug 1524358: remove slugid and commit message from .taskcluster.yml. rs=bustage-fix

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
(Assignee)

Comment 2

3 months ago

[COMM-BETA Approval Request Comment]
Regression caused by (bug #): 1524358
User impact if declined: Builds fail at decision task
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky):
No risk.
Mozilla-central has already uplifted their changes to beta.

Attachment #9041236 - Flags: approval-comm-beta?
(Assignee)

Comment 3

3 months ago
Comment on attachment 9041236 [details] [diff] [review]
.taskcluster.yml bustage fix

[COMM-ESR60 Approval Request Comment]
Regression caused by (bug #): 1524358
User impact if declined: Builds fail at decision task
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky):
No risk.
Mozilla-central plans to uplift this to esr60.
Attachment #9041236 - Flags: approval-comm-esr60?
(Assignee)

Updated

3 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

3 months ago
Comment on attachment 9041236 [details] [diff] [review]
.taskcluster.yml bustage fix

I'll check ESR uplift.
Attachment #9041236 - Flags: approval-comm-beta? → approval-comm-beta+

Updated

3 months ago
Target Milestone: --- → Thunderbird 67.0
Version: 67 → Trunk
Comment hidden (obsolete)
(Assignee)

Comment 6

3 months ago

Work on bug 1520874 led to failures when pushing to try-comm-central using
the "try:" syntax in a commit message.

This commit changes the call to get_hg_commit_message. Instead of passing
the root path of the Gecko checkout, the full path of "product-dir" is passed.
There's no need to find the actual root as "hg log" will work no matter where
in the tree it is executed.

Attachment #9041321 - Attachment is obsolete: true

Comment 8

3 months ago
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/integration/autoland/rev/00f00bf8cdf1
Support retrieval of comm repo commit messages. r=aki
Status: REOPENED → RESOLVED
Last Resolved: 3 months ago3 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1525956

Hi! I think this is almost done. I still see

https://hg.mozilla.org/comm-central/file/tip/.taskcluster.yml#l20

      _pushComment: {$if: 'tasks_for == "cron" || tasks_for == "action"', then: '', else: {$eval: 'push.comment'}}

but _pushComment doesn't appear elsewhere in the file. So, I think we can just remove that line. I'll make a patch in a sec.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment is particularly critical, since it is based on push.comment which soon
won't exist.

This also copies some explanatory comments about the context in which this file
is interpreted from mozilla-central.

Comment 15

2 months ago
Status: REOPENED → RESOLVED
Last Resolved: 3 months ago2 months ago
Resolution: --- → FIXED
(Assignee)

Comment 16

2 months ago

Comment on attachment 9042238 [details]
Bug 1525072 - remove unused context variables

[COMM-BETA Approval Request Comment]
Regression caused by (bug #): 1524358
User impact if declined: Builds fail at decision task
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky):
No risk.
This is an additional update to the previous patches, a couple of lines that should have been removed were not.

[COMM-ESR60 Approval Request Comment]
Regression caused by (bug #): 1524358
User impact if declined: Builds fail at decision task
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky):
No risk.
This is an additional update to the previous patches, a couple of lines that should have been removed were not.

Attachment #9042238 - Flags: approval-comm-esr60?
Attachment #9042238 - Flags: approval-comm-beta?

Comment 17

2 months ago

Comment on attachment 9042238 [details]
Bug 1525072 - remove unused context variables

OK, we check ESR when the time comes, OK?

Attachment #9042238 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 19

a month ago
Summary: Port bug 1520874, Remove slugid and push comment from .taskcluster.yml → Port bug 1524358, Remove slugid and push comment from .taskcluster.yml

Updated

a month ago
Attachment #9041236 - Flags: approval-comm-esr60? → approval-comm-esr60+

Updated

a month ago
Attachment #9042238 - Flags: approval-comm-esr60? → approval-comm-esr60+

If the decision ran correctly, that's pretty much evidence that it worked!

Comment 22

a month ago

Thanks for looking, Dustin. I asked because both patches needed rebasing, for example if you compare
beta: https://hg.mozilla.org/releases/comm-beta/rev/7b3232d39834
with
ESR: https://hg.mozilla.org/try-comm-central/rev/044f908fc99b85ba1f46bbd77399dbaa0d53a27c

The second changeset became a "comment only" since the _pushDate:and _pushComment: wasn't in the ESR to start with. Strangely the second push:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=61701b4c41ba0781338cf48b548de12e8c8ccc54
sadly didn't build anything, not even when redone:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=b893a357341b9c6dd2d4589de68ba3e5f21d572d

Let's see if I get feedback from Rob before m-esr60 at 60.6 becomes available which is when I need to push this.

Hm, it's possible that's because get_hg_commit_message gets the commit message for the wrong repo.

taskcluster/taskgraph/decision.py

    parameters['message'] = try_syntax_from_message(
            get_hg_commit_message(os.path.join(GECKO, product_dir)))                                                                                                                                                                                           

looks like it does the right thing, though.

Comment 24

a month ago

Hmm, what you quoted there is for trunk from here, no?
https://hg.mozilla.org/mozilla-central/rev/7d289fe21aec#l1.40

I was pushing from comm-esr60 to try-comm-central. That has worked in the past, I could push from comm-central, comm-beta and comm-esr60, which was very handy. Today I noticed that the builds don't start, see comment #22.

It has already not worked for beta here, 6th of March:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=e108217840869de16a92eed31603ea3f9b0ad8a1

Last time I did an ESR build that way was here, 9th of Feb:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=bec21e91a896bec6f5dd515ed0a4634b94262012

I should file a new bug for that.

Comment 25

a month ago

Filed bug 1534204.

Ah, I misunderstood the comments above -- it seems that this is not yet ported to esr60. At least, I still see as_slugid and push.comment in https://hg.mozilla.org/releases/comm-esr60/file/tip/.taskcluster.yml.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 27

a month ago

Dustin, yes, the changes haven't been committed to c-esr60 yet. There was only a try run so far:
https://hg.mozilla.org/try-comm-central/graph/d04633b2b37fc4e892fe9000fb70fae9bab28009

Once landed on c-esr60 in the next couple of days, there will only be as_slugid left which is also still used on M-C trunk:
https://searchfox.org/mozilla-central/search?q=as_slugid&case=false&regexp=false&path=

Status: REOPENED → RESOLVED
Last Resolved: 2 months agoa month ago
Resolution: --- → FIXED

Updated

14 days ago
Flags: needinfo?(rob)
You need to log in before you can comment on or make changes to this bug.