Closed Bug 1525099 Opened 10 months ago Closed 9 months ago

Standard content blocking is highlighted regardless of what option is selected

Categories

(Toolkit :: Preferences, defect, P1)

67 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- verified
firefox67 --- verified

People

(Reporter: sdp.misc, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: [triagemonth-2019-02])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Load "about:preferences#privacy"
  2. Under "Content Blocking", select strict or custom
  3. Reload the page

Actual results:

The standard option is highlighted and expanded.

Expected results:

Strict or custom (whichever was selected) should be highlighted and expanded.

Component: Untriaged → Preferences
Product: Firefox → Toolkit

I can reproduce this issue on Firefox 66 Beta and Firefox 67 Nightly but not in Firefox Release 65 in Windows 10, 64bit.
So, this must be a regression. I will try and find the regression range.

Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Whiteboard: [triagemonth-2019-02]

Likely same fix as for bug 1524995. Zibi is investigating bug 1524995 currently.

Priority: -- → P1
See Also: → 1524995

Regression from bug 1520350. Reverting that patch fixes this bug.

Blocks: 1520350
No longer blocks: 1518252

(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #4)

Regression from bug 1520350. Reverting that patch fixes this bug.

This doesn't make sense, because bug 1520350 is not on beta, and comment #1 and comment #2 says beta is affected.

Flags: needinfo?(gandalf)

(In reply to :Gijs (he/him) from comment #5)

(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #4)

Regression from bug 1520350. Reverting that patch fixes this bug.

This doesn't make sense, because bug 1520350 is not on beta, and comment #1 and comment #2 says beta is affected.

... and indeed, I can reproduce on beta.

Thanks! Testing on beta.

Can you verify that with that patch reverted you cannot reproduce on Nightly?

Flags: needinfo?(gandalf) → needinfo?(gijskruitbosch+bugs)

I can still reproduce the issue on 66.0b5 Windows10 with new profile.
Build ID 20190204181317
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

I was also able to reproduce it on Linux, but the behavior is:

  1. Open browser (66b5)
  2. Go to Preferences and select Strict policy and Always use private browsing mode
  3. Restart browser
  4. Open Preferences
  5. Strict policy is selected and all three checkboxes under Always use private browsing mode are unchecked
  6. ctrl+r to reload
  7. Now Standard policy is selected and two of the three checkboxes are checked

I see the same behavior in Nightly with the patch from bug 1520350 backed out.

So to sum up my current understanding:

  1. With bug 1520350 I see it reliably
  2. Without it, I see it after reload on both beta and nightly

That makes me think that there's some other underlying problem that potentially bug 1520350 made more visible.

Continue investigating.

Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
See Also: → 1526274
Duplicate of this bug: 1525234
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4ae67123a816
correctly select the right content blocking option, r=ewright
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment on attachment 9042459 [details]
Bug 1525099 - correctly select the right content blocking option, r?johannh

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

1520350, 1518252

User impact if declined

Confusing UI in the preferences/options

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

See comment #0, comment 10

List of other uplifts needed

n/a

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Very small, well-understood JS-only change to this specific bit of the preferences

String changes made/needed

no

Attachment #9042459 - Flags: approval-mozilla-beta?
Blocks: 1518252
Flags: qe-verify+
Whiteboard: [triagemonth-2019-02] → [triagemonth-2019-02][qa-triaged]

Hello ,

I have reproduced this issue with the FF Nightly build from 2019-02-04.

This issue is verified fixed on the latest FF Nightly(buildID: 20190212095015) on Win 10x64,macOS10.11 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9042459 [details]
Bug 1525099 - correctly select the right content blocking option, r?johannh

UI fix for content blocking options, verified in nightly.
OK for uplift for beta 8.

Attachment #9042459 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have re-verified this issue again in the 66.0b8(BuildID: 20190214102000 Build from taskcluster) on Win 10x64. Ubuntu 16.04 and macOS 10.12. Confirming this as verified fixed.

QA Whiteboard: [qa-triaged]
Whiteboard: [triagemonth-2019-02][qa-triaged] → [triagemonth-2019-02]
You need to log in before you can comment on or make changes to this bug.