Closed Bug 1525186 Opened 10 months ago Closed 6 months ago

[about:addons] Record the HTML about:addons pref in telemetry

Categories

(Toolkit :: Add-ons Manager, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- disabled
firefox68 + fixed
firefox69 --- fixed

People

(Reporter: mstriemer, Assigned: robwu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [feature-scope])

Attachments

(2 files)

It could be useful to know which version of about:addons a user is interacting with. Recording the value of the extensions.newaboutaddons.enabled pref should accomplish that.

Whiteboard: [feature-scope]
Blocks: 1533795
No longer blocks: 1505924
Priority: P2 → P1
Summary: Record the HTML about:addons pref in telemetry → [about:addons] Record the HTML about:addons pref in telemetry

Migrating the about:addons page from XUL to HTML, we want to be able to determine if the telemetry we're receiving is from one or the other. This request is to be able to tell that by including the value of the pref available in 68 only.

Attachment #9069841 - Flags: data-review?(chutten)
Type: enhancement → task
Comment on attachment 9069841 [details]
data_collection_request_1525186.txt

Preliminary notes:

Please file a follow-up bug to remove the collection in 69 or make a note in the pref removal bug that the removal must include the collection.

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is a userPref in the Telemetry Environment so is documented in [TelemetryEnvironment.jsm](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/app/TelemetryEnvironment.jsm).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire in Firefox 69.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. :ddurst is responsible for removing the collection before it expires.

---
Result: datareview+
Attachment #9069841 - Flags: data-review?(chutten) → data-review+
Assignee: nobody → rob
Status: NEW → ASSIGNED
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/07c14526637d
Record whether HTML about:addons is enabled in telemetry r=chutten

Comment on attachment 9070853 [details]
Bug 1525186 - Record whether HTML about:addons is enabled in telemetry

Beta/Release Uplift Approval Request

  • User impact if declined: Telemetry from interactions on the about:addons page would be ambiguous.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch adds a pref to an existing set of preferences in TelemetryEnvironment.
  • String changes made/needed: none
Attachment #9070853 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify-

Comment on attachment 9070853 [details]
Bug 1525186 - Record whether HTML about:addons is enabled in telemetry

telemetry for new about:addons, approved for 68.0b10

Attachment #9070853 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.