Closed Bug 1525218 Opened 2 years ago Closed 8 months ago

Use minidump_stackwalk toolchain artifacts instead of tooltool packages

Categories

(Testing :: General, enhancement, P3)

Version 3
enhancement

Tracking

(firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox74 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file, 2 obsolete files)

Bug 1391408 added toolchain tasks that build minidump_stackwalk for linux, osx and win32, corresponding to the tooltool packages we are currently using.

Bug 1519353 imported the changes we had in those tooltool packages against the in-tree version, so that the results of the toolchain tasks is now equivalent.

Those toolchain tasks artifacts should now be used instead of the tooltool packages for tests on automation.

Depends on: 1391408, 1519353
Flags: needinfo?(ajones)

Joel - is this your department?

Flags: needinfo?(ajones) → needinfo?(jmaher)
Flags: needinfo?(ajones)

:ahal, can you put this in your queue- My only question here would be android as we have different needs there and will probably need to support both models. Assuming this works on android, it would reduce some headaches on android hardware at bitbar since we currently rebuild docker images to include tooltool artifacts.

Flags: needinfo?(jmaher) → needinfo?(ahal)

We presumably don't need minidump_stackwalk running on android itself. Isn't it supposed to be run by the harness on the linux host?

it is run on the linux hosts, not sure if we need to do something different as the stack comes from android

fwiw, aerickson is testing a new bitbar image without the prepopulated tooltool cache since bitbar has added --dns to the container start command. It looks promising and we should know for sure later today.

The image passed testing and is now in production. We no longer cache the tooltool downloads in the bitbar image.

Android should need no special treatment: It just uses the linux64 minidump_stackwalk.

Priority: -- → P3

I stumbled upon how to do it while looking for an answer to bug 1543624 comment 2.

Assignee: nobody → mh+mozilla
Depends on: 1543893
Depends on: 1543894
Depends on: 1543895
Depends on: 1525373
Depends on: 1545368
Flags: needinfo?(ajones)
Depends on: 1547903

Sorry, never got a chance to look at this and it's not clear that it'll become a top priority for me anytime soon. If glandium doesn't end up getting to it first, let's leave it in our normal triage process (P3 seems reasonable for now, though feel free to bump to P2).

Flags: needinfo?(ahal)

I actually have a patch already, but it's blocked on bug 1557614.

Depends on: 1568460
Depends on: 1569231
Depends on: 1578963
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/eb4b265deb5e
Use minidump_stackwalk toolchain artifacts instead of tooltool packages. r=froydnj
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/9c66ecb1f66c
Fixup for xpcshell tests fetches.
Regressions: 1609615
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
See Also: → 1609754
See Also: 1609754

Backed out for breaking raptor speedometer tests on mobile repositories (e.g. fenix, reference-browser) due to missing minidump_stackwalk (bug 1609754) on request from igoldan:
https://hg.mozilla.org/integration/autoland/rev/52c8276357213c93e91657b6d0ce6002e1e05af3

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla74 → ---
See Also: → 1611603

I just discovered that builds also are using a mix of tooltool and trying to use build/tools (but that repo isn't checked out so they point to a non-existant file).

https://searchfox.org/mozilla-central/search?q=MINIDUMP_STACKWALK&path=testing%2Fmozharness%2Fconfigs%2Fbuilds

Mmmmm how come I didn't alter those?

(In reply to Tom Prince [:tomprince] from comment #21)

I just discovered that builds also are using a mix of tooltool and trying to use build/tools (but that repo isn't checked out so they point to a non-existant file).

https://searchfox.org/mozilla-central/search?q=MINIDUMP_STACKWALK&path=testing%2Fmozharness%2Fconfigs%2Fbuilds

Moved that part to bug 1613561 because it doesn't actually depends on this bug.

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/7dcafc398876
Use minidump_stackwalk toolchain artifacts instead of tooltool packages. r=froydnj
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Attachment #9121214 - Attachment is obsolete: true
Attachment #9121237 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.