Closed Bug 1525262 Opened 8 months ago Closed 7 months ago

Dedicated Profile tries to create a deleted profile

Categories

(Toolkit :: Startup and Profile System, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox66 + wontfix
firefox67 --- verified

People

(Reporter: Ovidiu, Assigned: mossop)

References

Details

Attachments

(1 file)

Affected versions

  • Nightly 67.0a1

Affected platforms
Mac OS, Windows

Prerequisites
*You need to use a clean install on your computer.

Steps to reproduce

  1. Install and open a build that has Dedicated Profiles feature
  2. Go to profiles folder (type in URL bar about:profiles and click on "Show in Finder" from "Root Directory" section)
  3. Close the browser
  4. Delete the profile that was previously used - now you have only the default profile
  5. Try to open the browser from step 1.

Expected result

  • The browser should open.

Actual result

  • You are prompted with an error: "A copy of Firefox is already open. Only one copy of Firefox can be open at a time"

Additional notes

  • If you look into profiles.ini folder you will see that the deleted profile from step 4 is listed.
  • We will test it on Ubuntu and we will update the report.

So this mostly matches the behaviour of previous versions, though it seems the dialog message has changed, it used to say that the profile could not be found which makes more sense. Not sure exactly what a better behaviour would be here but I don't think this is a major issue for shipping.

Assignee: nobody → dtownsend

[Tracking Requested - why for this release]:

This is a regression from bug 1518587. Users will get an incorrect message when they start Firefox when their profile folder is missing. Not sure if it is worth taking for beta since it is only a minor issue though.

Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/211b6d23cac0
Always show the profile missing dialog if the selected profile does not exist. r=froydnj
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Hard to tell how common this would be. We're not even at the halfway point for beta so uplift might be OK.

mossop, how would you assess the risk with uplift? Do we have any sort of test coverage for dedicated profile code?

Flags: needinfo?(dtownsend)

I don't think this should be uplifted, dedicated profiles feature is enabled only on Nightly and it will go with the trains.

This was actually caused by some code that changed in the run up to supporting dedicated profiles. The fix here is pretty simple. But that said this is such a trivial issue that almost no-one will hit that I'm not really that bothered if we don't uplift.

Flags: needinfo?(dtownsend)

We verified this on Mac OS X 10.14, Windows 10, Ubuntu 16.04 and now if I want to open a deleted profile I'm prompted with an error that informs you about the fact that the profile that you want to open is missing or inaccessible.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.