Closed Bug 1525367 Opened 3 years ago Closed 3 years ago

reintroduce double-click-toggle to about:config

Categories

(Toolkit :: Preferences, defect)

Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1504254

People

(Reporter: Gankra, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

When quickly toggling a few related settings (as is common when working on webrender), it's easier to double-click the preference's label than to find the label and then scan to the right to find the associated toggle button.

Keywords: regression
OS: Unspecified → All
See Also: → 1504254

We decided against this behaviour to enable the "usual" copy-paste approach.
Do you have a good and accessible idea to copy and paste the pref names and values without having the opportunity to mark them?

We support the <menu> element to add stuff to the context menu, that could be a way. Also you could specify user-select: all on the pref name to select it all with a single click, maybe.

Marking with a single click and editing with a double click sounds very confusing.
The idea was to get rid of the context menues, so that all "features" of the page a visible within a glance.

(though just tried locally and that doesn't look extremely nice).

Anyhow, you should be able to implement whatever UI you want for clipboard, we should have APIs for that, like dom.event.clipboardevents.enabled.

Note that I'm terrible at UI / UX so my comments re. that should probably be taken with a grain of salt :)

Sorry for comment 4, mid-aired :)

(In reply to :Matthias Kammüller from comment #3)

Marking with a single click and editing with a double click sounds very confusing.
The idea was to get rid of the context menues, so that all "features" of the page a visible within a glance.

That's fine, I'm not too attached to the double-click thing, was just trying to provide suggestions. It's fine (for me, at least) if you don't take them because you think they don't fit :)

Maybe double-clicking outside of the text / buttons, on the whitespace area of the row, could still toggle it? Again, not sure it's an improvement :)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #5)

Maybe double-clicking outside of the text / buttons, on the whitespace area of the row, could still toggle it? Again, not sure it's an improvement :)

I fear that that would make things rather complicated as well.
Double clicking seems to be a popular feature, but I cannot think of a good way to keep it :(

Yes, we'll stick to the agreed upon design. We already decided to make a brand new interface. As you can already see, trying to bring back individual design elements from the old interface only results in more issues being raised.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1504254

ok that makes sense. :)

Would it instead make sense to move the toggle/reset buttons to the left side, since they're small and fixed-width? That way the visual distance between the label and the button is minimized?

The buttons are not fixed-width, they correspond with the width of the text. Should "edit" be longer in some language, this might look different.

You need to log in before you can comment on or make changes to this bug.