Closed Bug 1525422 Opened 2 years ago Closed 2 years ago

Unicode ellipses fail : three-period ellipses is not replaced with single unicode ellipsis character

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1521915
Tracking Status
firefox67 --- fixed

People

(Reporter: bnagabandi, Unassigned)

References

Details

Attachments

(1 file)

Depends on bug 1521915

FF Nightly version : 67.0a1 (2019-02-05)

On the latest FF Nightly build, unicode ellipsis character is missing.

Long text that get truncated with ". . ." doesn't indicate with …

Observations :

  • Issue is mostly found for the Hero Card titles (Large cards)
  • Excerpts that require ellipses unicode character show expected. (can be found in the recording)
  • Not all the Titles and excerpts has this ellipses unicode (is it manditory for all of those? )

Screenshot attached.

recording : https://www.dropbox.com/s/w2x27zwkkeb5z3u/Bugzy%20-%20Issue%20-%201525422.mp4?dl=0

Depends on: 1521915, 1522299
No longer depends on: 1521915
Blocks: 1521915

End-point used :
Pref browser.newtabpage.activity-stream.discoverystream.config ={"enabled":true,"show_spocs":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}

The video and attachment image seems to show ellipses instead of 3 periods for me ???

Flags: needinfo?(bnagabandi)

Issue is mostly found for the Hero Card titles (Large cards).
Actually it is little confusing and looks like 3 periods for me instead of ellipses (may be the because of the size) :)

Flags: needinfo?(bnagabandi)

The decision that was made between Wolasi and Gavin that we will no longer support any ellipsis at all, since it is too hard to do correctly.

This change was landed in https://bugzilla.mozilla.org/show_bug.cgi?id=1524321 and should be available in nightly.

Please verify that you no longer see any ellipsis / ellipsis issues.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bnagabandi)
Resolution: --- → FIXED
Depends on: 1524321
Priority: -- → P1

QA Results:

Tested on :

FF Nightly version : 67.0a1 (2019-02-10)
OS : Mac and Windows 10 Pro

Ellipsis no longer exist.

QA Results (Recording) : https://www.dropbox.com/s/ib0eg1z5xbjxcnv/QA%20Results%20%28recording%29%20%3A%20bug%201525422.mp4?dl=0

Closing as verified.

Flags: needinfo?(bnagabandi)
Status: RESOLVED → VERIFIED
Status: VERIFIED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1521915
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.