Closed Bug 1525478 Opened 1 year ago Closed 1 year ago

Certain CSS animations cause extreme framerate drops (because hardware-acceleration was blocked for nvidia driver 24.21.13.9731 on GeForce GTX 760)

Categories

(Core :: Performance, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ivarhill, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [qf:p5:responsiveness])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Many CSS animations lead to extreme performance drops of a few frames a second - in particular while scrolling.

Here is an example which consistently reproduces the issue here: https://codepen.io/anon/pen/aXLpPO - this particular case animates the opacity and scale of a div that has a background image and blending mode applied, but performance dips happen with a multitude of variations of animated properties.

My current workstation has an i5-3350P CPU, 12gb of RAM, and a GTX760 GPU.

Actual results:

Framerate drops enormously, and even more so when scolling while the div animates.

Performance analysis can be found here: https://perfht.ml/2TtwuDn

Expected results:

Testing in other browsers, framerate is a constant 60FPS. This is not the case in Firefox, regardless of edition or WebRender being on or off.

Component: Untriaged → Performance
Product: Firefox → Core
Whiteboard: [qf]

(In reply to Ivar Hill from comment #0)

Performance analysis can be found here: https://perfht.ml/2TtwuDn

This is showing that BasicCompositor is being used; in other words, hardware-acceleration is off. Can you check the graphics section on about:support for the reason why it's off?

Flags: needinfo?(ivarhill)
Whiteboard: [qf] → [qf:p4:responsiveness]
Whiteboard: [qf:p4:responsiveness] → [qf:p5:responsiveness]
Flags: needinfo?(ivarhill)

(In reply to Markus Stange [:mstange] from comment #1)

(In reply to Ivar Hill from comment #0)

Performance analysis can be found here: https://perfht.ml/2TtwuDn

This is showing that BasicCompositor is being used; in other words, hardware-acceleration is off. Can you check the graphics section on about:support for the reason why it's off?

That is interesting, in about:preferences hardware acceleration is turned on. I attached a screenshot of the entire Graphics section in about:support - I don't know enough of it to get a better sense of things, but by the looks of it there may be driver issues?

Ok, it says "D3D11_COMPOSITING: Blocklisted due to known issues bug 1457758".

Can you try updating your nvidia driver?

Blocks: 1457758
Keywords: regression

Updated my GPU drivers and about:support now shows compositing as 'WebRender' and performance is vastly improved. Definitely seems like that was the culprit.

Great! We probably won't do anything about the driver being blocked, but thanks for providing the feedback.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
Summary: Certain CSS animations cause extreme framerate drops → Certain CSS animations cause extreme framerate drops (because hardware-acceleration was blocked for nvidia driver 24.21.13.9731 on GeForce GTX 760)
You need to log in before you can comment on or make changes to this bug.