Closed Bug 1525553 Opened 2 years ago Closed 1 year ago

Sources pane is empty when debugging extensions

Categories

(DevTools :: about:debugging, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jdescottes, Unassigned)

References

(Blocks 1 open bug)

Details

STRs:

  • open about:debugging,
  • click debug for any extension,
  • select the Debugger

-> "Sources pane" is empty

Seems like a recent regression, currently looking for the regression window.

Looks like this was an issue with my Browser Toolbox profile. I accidentally turned off devtools.chrome.enabled, maybe via the DevTools settings?

And recently the debugger started checking the devtools.chrome.enabled pref in order to hide/show webextension sources in the debugger (release 121, PR https://github.com/devtools-html/debugger.html/pull/7705).

Two things:

  • it would be nice if the empty state for the sources pane was not a blank panel
  • we should make sure that toolboxes that want to debug addons have this pref turned on. It is a bit weird, because it is a profile setting. And maybe you don't want to see webextensions when debugging regular pages, but you still want to debug extensions from about debugging.

Maybe we need a shared helper to know if webextension sources should be visible, and it could compute that based on a combination of this preference and "is the current target a webextension".

Overall the responsibility of devtools.chrome.enabled is a bit weird. It's mostly a client side preference (only used in the storage actor on the server).

We no longer use a dedicated profile so this is less likely to happen, especially since we force users to set devtools.chrome.enabled to true for local extension debugging, via the "Enable extensions debugging" checkbox.

Status: NEW → RESOLVED
Closed: 1 year ago
Priority: -- → P3
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.