Enable promise rejection event

RESOLVED FIXED in Firefox 69

Status

()

enhancement
P2
normal
RESOLVED FIXED
5 months ago
2 days ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

(Depends on 1 bug, Regressed 1 bug, {dev-doc-needed})

Trunk
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox ?, firefox69 fixed)

Details

Attachments

(4 attachments, 3 obsolete attachments)

No description provided.
Assignee: nobody → echen
Depends on: 1362272
Priority: -- → P2

It will cause the result of some tests to change, given that testharness.js is meant to fail if there are unhandled rejections [1].

[1] https://searchfox.org/mozilla-central/rev/9eb30227b21e0aa40d51d9f9b08bb0b113c5fadb/testing/web-platform/tests/resources/testharness.js#3278-3310

Attachment #9041754 - Attachment description: Bug 1525554 - Enable promise rejction event on nightly and update tests result; → Bug 1525554 - Enable promise rejection event on nightly and update tests result;
Component: DOM → DOM: Core & HTML
Depends on: 1549351

which causes the promise being rejected and testharness reports error given
that there are unhandled rejected promises

Attachment #9041754 - Attachment is obsolete: true
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67cd5b8663ca
Fix "MojoInterfaceInterceptor is not defined" error; r=annevk
Attachment #9066565 - Attachment is obsolete: true
Attachment #9067011 - Attachment description: Bug 1525554 - Avoid testharness reporting error casued by unhandled rejected promises in pause-remove-from-document-networkState.html; → Bug 1525554 - Avoid testharness reporting error casued by unhandled promise rejections in pause-remove-from-document-networkState.html;
Attachment #9067011 - Attachment description: Bug 1525554 - Avoid testharness reporting error casued by unhandled promise rejections in pause-remove-from-document-networkState.html; → Bug 1525554 - Avoid testharness reporting unhandled promise rejections in pause-remove-from-document-networkState.html;
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e7f893e8020
Avoid testharness reporting error casued by unhandled rejected promises in media-source/mediasource-getvideoplaybackquality.html; r=annevk
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/617ee0765a32
Avoid testharness reporting unhandled promise rejections in pause-remove-from-document-networkState.html; r=annevk
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17066 for changes under testing/web-platform/tests
Can't merge web-platform-tests PR due to failing upstream checks:
Github PR https://github.com/web-platform-tests/wpt/pull/17066
* Taskcluster (pull_request) (https://tools.taskcluster.net/task-group-inspector/#/McH97AogSUan1VKDu9oNQg)
Upstream PR merged

pref dom.promise_rejection_events.enabled default value should be changed to true

Attachment #9068315 - Attachment is obsolete: true

Enabling on nightly only doesn't work because it will cause the test starts to fail after merged into beta or release. So we should just enable on everywhere.

Summary: Enable promise rejection event on Nightly → Enable promise rejection event
Attachment #9065904 - Attachment description: Bug 1525554 - Enable promise rejection event on nightly and update tests result; → Bug 1525554 - Enable promise rejection event and update tests result;
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d629658891ae
Enable promise rejection event and update tests result; r=smaug
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

(In reply to Release mgmt bot [:sylvestre / :calixte] from comment #29)

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

As this is to enable a new feature on 69, I think we should move status-firefox67 and status-firefox68 to default ---.

Regressions: 1557060
Depends on: 1550290
Depends on: 1560511

Release Note Request (optional, but appreciated)
[Why is this notable]: While implementing Promises, developers need to handle rejections and catch them accordingly, but sometimes they may not. This feature is useful for debugging, for general application resiliency, and for providing fallback error handling for unexpected situations.
[Affects Firefox for Android]: yes
[Suggested wording]:
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Web/API/PromiseRejectionEvent

relnote-firefox: --- → ?
Regressions: 1566982
You need to log in before you can comment on or make changes to this bug.