Closed Bug 1525556 Opened 8 months ago Closed 8 months ago

Intermittent LeakSanitizer | leak at js_arena_realloc, GetOrCreateDOMReflector, GetOrCreate, GetOrCreateDOMReflector

Categories

(Testing :: web-platform-tests, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Assigned: mccr8)

References

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=226432796&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/GVdLZAPsQlmlh1p7LmK-jw/runs/0/artifacts/public/logs/live_backing.log

[task 2019-02-06T10:04:29.660Z] 10:04:29 INFO - TEST-OK | /payment-handler/same-object-attributes.https.html | took 1252ms
[task 2019-02-06T10:04:29.661Z] 10:04:29 INFO - TEST-START | /payment-handler/untrusted-event.https.html
[task 2019-02-06T10:04:29.665Z] 10:04:29 INFO - Closing window 34359738369
[task 2019-02-06T10:04:29.770Z] 10:04:29 INFO - PID 29745 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-02-06T10:04:31.751Z] 10:04:31 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350100,name=PContent::Msg_AccumulateChildHistograms) Closed channel: cannot send/recv
[task 2019-02-06T10:04:31.751Z] 10:04:31 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350101,name=PContent::Msg_AccumulateChildKeyedHistograms) Closed channel: cannot send/recv
[task 2019-02-06T10:04:31.751Z] 10:04:31 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350102,name=PContent::Msg_UpdateChildScalars) Closed channel: cannot send/recv
[task 2019-02-06T10:04:31.752Z] 10:04:31 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350105,name=PContent::Msg_RecordDiscardedData) Closed channel: cannot send/recv
[task 2019-02-06T10:04:35.469Z] 10:04:35 INFO - PID 29745 | -----------------------------------------------------
[task 2019-02-06T10:04:35.470Z] 10:04:35 INFO - PID 29745 | Suppressions used:
[task 2019-02-06T10:04:35.471Z] 10:04:35 INFO - PID 29745 | count bytes template
[task 2019-02-06T10:04:35.472Z] 10:04:35 INFO - PID 29745 | 242 7712 nsComponentManagerImpl
[task 2019-02-06T10:04:35.472Z] 10:04:35 INFO - PID 29745 | 2 416 mozJSComponentLoader::LoadModule
[task 2019-02-06T10:04:35.473Z] 10:04:35 INFO - PID 29745 | 611 17713 libfontconfig.so
[task 2019-02-06T10:04:35.473Z] 10:04:35 INFO - PID 29745 | 1 29 libglib-2.0.so
[task 2019-02-06T10:04:35.473Z] 10:04:35 INFO - PID 29745 | -----------------------------------------------------
[task 2019-02-06T10:05:00.457Z] 10:05:00 INFO - .
[task 2019-02-06T10:05:00.458Z] 10:05:00 INFO - TEST-TIMEOUT | /payment-handler/untrusted-event.https.html | took 30796ms
[task 2019-02-06T10:05:00.523Z] 10:05:00 INFO - PID 29745 | 1549447500515 Marionette INFO Stopped listening on port 2828
[task 2019-02-06T10:05:00.844Z] 10:05:00 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350100,name=PContent::Msg_AccumulateChildHistograms) Closed channel: cannot send/recv
[task 2019-02-06T10:05:00.844Z] 10:05:00 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350101,name=PContent::Msg_AccumulateChildKeyedHistograms) Closed channel: cannot send/recv
[task 2019-02-06T10:05:00.844Z] 10:05:00 INFO - PID 29745 | ###!!! [Child][MessageChannel] Error: (msgtype=0x350105,name=PContent::Msg_RecordDiscardedData) Closed channel: cannot send/recv
[task 2019-02-06T10:05:00.844Z] 10:05:00 INFO - PID 29745 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2019-02-06T10:05:02.020Z] 10:05:02 INFO - PID 29745 | -----------------------------------------------------
[task 2019-02-06T10:05:02.020Z] 10:05:02 INFO - PID 29745 | Suppressions used:
[task 2019-02-06T10:05:02.020Z] 10:05:02 INFO - PID 29745 | count bytes template
[task 2019-02-06T10:05:02.022Z] 10:05:02 INFO - PID 29745 | 242 7712 nsComponentManagerImpl
[task 2019-02-06T10:05:02.022Z] 10:05:02 INFO - PID 29745 | 3 624 mozJSComponentLoader::LoadModule
[task 2019-02-06T10:05:02.022Z] 10:05:02 INFO - PID 29745 | 611 17713 libfontconfig.so
[task 2019-02-06T10:05:02.022Z] 10:05:02 INFO - PID 29745 | 1 29 libglib-2.0.so
[task 2019-02-06T10:05:02.022Z] 10:05:02 INFO - PID 29745 | -----------------------------------------------------
[task 2019-02-06T10:05:02.230Z] 10:05:02 INFO - PID 29745 | -----------------------------------------------------
[task 2019-02-06T10:05:02.231Z] 10:05:02 INFO - PID 29745 | Suppressions used:
[task 2019-02-06T10:05:02.231Z] 10:05:02 INFO - PID 29745 | count bytes template

Assignee: nobody → continuation
Component: JavaScript Engine → web-platform-tests
Product: Core → Testing

This is another issue where we're missing a JS function in the top-level WPT LSan whitelist. In this case, js_arena_realloc. I'll land this fix as part of bug 1522500.

Depends on: 1522500

This shouldn't happen any more because I hid the leak.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.