Show cached data immediately on subsequent loads

VERIFIED FIXED in Firefox 66

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: andreio, Assigned: andreio)

Tracking

({github-merged})

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66+ verified, firefox67 verified)

Details

User Story

QA Steps:

1. Run Firefox with Discovery Stream on.
2. Make sure the `dev-test-all` variant is enabled.
3. Run the following code in the Browser Toolbox
  * https://gist.githubusercontent.com/piatra/a4de28d242721d4199f89a6d78e9f66e/raw/e5f7bbaf3d92a52bf01b597f8acb11096e927c84/steps.js
4. Notice the numbers associated with each component
5. Restart the browser and run the same code again. We expect to see the same numbers associated with the components.

Attachments

(5 attachments)

Assignee

Description

4 months ago

On startup we want to immediately show cached content (if it's less than a week old) and do a background fetch so that the next newtab or load will have fresh data.

Assignee

Updated

4 months ago
Assignee: nobody → andrei.br92

Updated

4 months ago
Iteration: --- → 67.1 - Jan 28 - Feb 10
Priority: -- → P1

[Tracking Requested - why for this release]:

Severity: normal → enhancement
Blocks: 1526066

Comment 3

4 months ago
Status: NEW → RESOLVED
Closed: 4 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Want to request uplift here? Is there some way to verify the fix?

Flags: needinfo?(andrei.br92)
Flags: qe-verify+
Assignee

Comment 6

4 months ago

Added QA steps in user story.

User Story: (updated)
Flags: needinfo?(andrei.br92)
Attachment #9043314 - Attachment description: Bug 15255581 - Show Activity Stream cached data immediately on subsequent loads → Bug 1525581 - Show Activity Stream cached data immediately on subsequent loads

Is this going to conflict with https://bugzilla.mozilla.org/show_bug.cgi?id=1525413? Does that need to land first?

Flags: needinfo?(andrei.br92)

Ok, so what you'll need to do to update this is:

  1. arc patch my https://phabricator.services.mozilla.com/D19577 diff and reset your phabricator branch to that
  2. In Github, cherry-pick your commit on top of my bug1525413-uplift branch (see: https://github.com/mozilla/activity-stream/compare/beta...k88hudson:bug1525413-uplift)
  3. npm run builduplift and commit the new diff, update your phabricator patch against HEAD^

Ping me if you have trouble

Assignee

Comment 9

4 months ago

Updated the patch waiting on bug 1520258 and bug 1525413 to get uplifted.

Flags: needinfo?(andrei.br92)
Assignee

Comment 10

4 months ago

QA needed. Please let me know if there are any issues with the steps.

Flags: needinfo?(bnagabandi)
Assignee

Comment 11

4 months ago

Comment on attachment 9043314 [details]
Bug 1525581 - Show Activity Stream cached data immediately on subsequent loads

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1512725

User impact if declined

Slower user experience at startup

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

QA steps in User Story

List of other uplifts needed

Bug 1525413

Risk to taking this patch

Medium

Why is the change risky/not risky? (and alternatives if risky)

This patch already landed in Nightly and has QA steps for verification.

String changes made/needed

Attachment #9043314 - Flags: approval-mozilla-beta?

Tested on :

FF Nightly version : 67.0a1 (2019-02-13)
OS : Mac and Windows 10 Pro

I'm getting syntax error on both OS. Have the pref settings as mentioned in QA steps.

  • Set the pref browser.newtabpage.activity-stream.discoverystream.config to {"enabled":true,"show_spocs":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}

I made sure to enable (via Settings) :

  • Enable browser chrome and add-on debugging toolboxes
  • Enable remote debugging

Is there anything I'm missing?

Flags: needinfo?(bnagabandi) → needinfo?(andrei.br92)

Comment on attachment 9043314 [details]
Bug 1525581 - Show Activity Stream cached data immediately on subsequent loads

After discussion with k88hudson we're going to go ahead and take this for beta 8.
It shouldn't cause problems for beta users on the whole since it's behind a pref, so we're OK to verify in beta after the uplift.

Attachment #9043314 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 14

4 months ago

QA Results : Pass

FF Nightly version : 67.0a1 (2019-02-14)
OS : Mac and Windows 10 Pro

I was able to test this after restarting browser.

Seeing the same counts and timestamps each time after every restart.

Below are attachments for Mac OS and Windows 10.

Flags: needinfo?(andrei.br92)

Comment 15

4 months ago

QA Results: Mac OS

QA Results: Windows 10 Pro

Closing as verified.

Updated

4 months ago
Status: RESOLVED → VERIFIED

(In reply to Brahmini Nagabandi from comment #14)

QA Results : Pass

FF Nightly version : 67.0a1 (2019-02-14)
OS : Mac and Windows 10 Pro

I was able to test this after restarting browser.

Seeing the same counts and timestamps each time after every restart.

Below are attachments for Mac OS and Windows 10.

Would you be so kind to verify the fix on 66.0b8 as well?
https://archive.mozilla.org/pub/firefox/candidates/66.0b8-candidates/build1/

Flags: needinfo?(bnagabandi)
Whiteboard: [qa-triaged]

(In reply to Bogdan Maris [:bogdan_maris], Release Desktop QA from comment #18)

(In reply to Brahmini Nagabandi from comment #14)

QA Results : Pass

FF Nightly version : 67.0a1 (2019-02-14)
OS : Mac and Windows 10 Pro

I was able to test this after restarting browser.

Seeing the same counts and timestamps each time after every restart.

Below are attachments for Mac OS and Windows 10.

Would you be so kind to verify the fix on 66.0b8 as well?
https://archive.mozilla.org/pub/firefox/candidates/66.0b8-candidates/build1/

Tested on BETA

QA Results: Pass

Tested on :

FF Beta version : 66.0b9 (64-bit)
OS : Mac and Windows 10 Pro

  • Followed QA steps as in user story
  • I have set pref browser.newtabpage.activity-stream.discoverystream.config to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}

Works as expected.

Flags: needinfo?(bnagabandi)
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]

(In reply to Brahmini Nagabandi from comment #20)

(In reply to Bogdan Maris [:bogdan_maris], Release Desktop QA from comment #18)

(In reply to Brahmini Nagabandi from comment #14)

QA Results : Pass

FF Nightly version : 67.0a1 (2019-02-14)
OS : Mac and Windows 10 Pro

I was able to test this after restarting browser.

Seeing the same counts and timestamps each time after every restart.

Below are attachments for Mac OS and Windows 10.

Would you be so kind to verify the fix on 66.0b8 as well?
https://archive.mozilla.org/pub/firefox/candidates/66.0b8-candidates/build1/

Tested on BETA

QA Results: Pass

Tested on :

FF Beta version : 66.0b9 (64-bit)
OS : Mac and Windows 10 Pro

  • Followed QA steps as in user story
  • I have set pref browser.newtabpage.activity-stream.discoverystream.config to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}

Works as expected.

Thanks for the verification, removing qe-verify flag as well.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.