[remote-dbg-next] UX-implementation: Runtime page categories

RESOLVED FIXED in Firefox 67

Status

enhancement
P1
normal
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: jdescottes, Assigned: daisuke)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(6 attachments, 2 obsolete attachments)

Reporter

Description

4 months ago

Follow up to Bug 1512637. We now have mockups to update the design of the debug categories:

https://mozilla.invisionapp.com/share/Y4Q4JXIBW32#/screens/342547179_Runtime_Variation_4_Body_Measurements

Reporter

Updated

3 months ago
Priority: -- → P2
Reporter

Updated

3 months ago
Duplicate of this bug: 1505123
Reporter

Comment 2

3 months ago

Matt, do you think you could add the empty state for runtime page categories to those mockups, instead of the current disabled state?

Our current text for empty categories is "Nothing yet."

Flags: needinfo?(mcroud)

Comment 3

3 months ago

I have updated the mockup. I have removed the previous "disabled" empty state and added the "Nothing yet" text along with the twisty arrow. I made the change to the Shared workers catgeory in the mockup.

Flags: needinfo?(mcroud)
Assignee

Updated

3 months ago
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
Assignee

Comment 9

3 months ago

Depends on D20297

Attachment #9044852 - Attachment description: Bug 1525615: Change the style of 'Nothing yet' label. r=jdescottes!,ladybenko! → Bug 1525615: Change the style of basic font-size and font-weight. r=jdescottes!,ladybenko!
Attachment #9044854 - Attachment is obsolete: true
Attachment #9044855 - Attachment is obsolete: true

Comment 12

3 months ago
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97ff6454af34
Change button style. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/a84ca43b06f0
Change the style of category title. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/c5fa70d3ef1e
Change the style of basic font-size and font-weight. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/383b66655783
Introduce 'card' style. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/54455c6ac7ca
Change the style of DebugTargetItem. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/c6f3144fb731
Add 'title' attribute to '<a>' of title of DebugTargetPane. r=jdescottes,ladybenko

Backed out for build bustages

Backout link: https://hg.mozilla.org/integration/autoland/rev/894e76afd6ba9ab4a56f871bf30bb686db02d891
Push link: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=c6f3144fb731c869d3ec6f300d1aec0c96eee4d4
Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=230513474&repo=autoland&lineNumber=37298

Log snippet:

[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> ERROR: The following duplicated files are not allowed:
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> browser/chrome/devtools/skin/images/aboutdebugging-collapse-icon.svg
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> browser/chrome/devtools/skin/images/arrow-e.svg
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> /builds/worker/workspace/build/src/toolkit/mozapps/installer/packager.mk:26: recipe for target 'stage-package' failed
[task 2019-02-26T11:34:33.880Z] 11:34:33 ERROR - package> make[5]: *** [stage-package] Error 1
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> make[5]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/browser/installer'
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> /builds/worker/workspace/build/src/toolkit/mozapps/installer/packager.mk:95: recipe for target 'make-package' failed
[task 2019-02-26T11:34:33.880Z] 11:34:33 ERROR - package> make[4]: *** [make-package] Error 2
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> /builds/worker/workspace/build/src/config/rules.mk:400: recipe for target 'default' failed
[task 2019-02-26T11:34:33.880Z] 11:34:33 ERROR - package> make[3]: *** [default] Error 2
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - package> /builds/worker/workspace/build/src/browser/build.mk:6: recipe for target 'package' failed
[task 2019-02-26T11:34:33.880Z] 11:34:33 ERROR - package> make[2]: *** [package] Error 2
[task 2019-02-26T11:34:33.880Z] 11:34:33 INFO - /builds/worker/workspace/build/src/build/moz-automation.mk:84: recipe for target 'automation/package' failed
[task 2019-02-26T11:34:33.881Z] 11:34:33 ERROR - make[1]: *** [automation/package] Error 2
[task 2019-02-26T11:34:33.881Z] 11:34:33 INFO - make[1]: *** Waiting for unfinished jobs....
[task 2019-02-26T11:34:48.753Z] 11:34:48 INFO - package-tests> make[3]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/js/src/tests'
[task 2019-02-26T11:34:48.753Z] 11:34:48 INFO - package-tests> ../../../config/nsinstall -D ../../../dist/test-stage/jsreftest/tests

Flags: needinfo?(dakatsuka)
Assignee

Comment 14

3 months ago

Thank you very much, Narcis!
It seems we should modify https://searchfox.org/mozilla-central/source/browser/installer/allowed-dupes.mn as well.

Flags: needinfo?(dakatsuka)

Comment 15

3 months ago
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a77368ca7fdf
Change button style. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/2aedb2fbe8e1
Change the style of category title. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/b309d8c1cfa9
Change the style of basic font-size and font-weight. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/c58658cd01ef
Introduce 'card' style. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/ea65fc3bc3a0
Change the style of DebugTargetItem. r=jdescottes,ladybenko
https://hg.mozilla.org/integration/autoland/rev/9b8bdd92d93e
Add 'title' attribute to '<a>' of title of DebugTargetPane. r=jdescottes,ladybenko
You need to log in before you can comment on or make changes to this bug.