Closed Bug 1525695 Opened 8 months ago Closed 8 months ago

ReferenceError: executeSoon is not defined- irc.js:1164:7

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 67.0

People

(Reporter: mkmelin, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

I'm getting an error

ReferenceError: executeSoon is not defined[Learn More] irc.js:1164:7

Attached patch 1525695-fix-executeSoon.patch (obsolete) — Splinter Review

I hope, it's only missing in this file. A lot other files have it defined: https://searchfox.org/comm-central/search?q=executeSoon&case=false&regexp=false&path=

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9041904 - Flags: review?(mkmelin+mozilla)
Attached patch bug1525695_irc_refs.patch (obsolete) — Splinter Review

Fixing the imports, and with this IRC seems to be working again.

I have to say, especially the TextboxSize usage looks wrong, working like some kind of global settings getter. That could be fixed in a later bug though.

Assignee: richard.marti → mkmelin+mozilla
Attachment #9041907 - Flags: review?(florian)
Attachment #9041904 - Flags: review?(mkmelin+mozilla)
Attachment #9041904 - Attachment is obsolete: true
Comment on attachment 9041907 [details] [diff] [review]
bug1525695_irc_refs.patch

Review of attachment 9041907 [details] [diff] [review]:
-----------------------------------------------------------------

jsProtoHelper.jsm also needs l10nHelper from imXPCOMUtils.jsm

::: chat/components/src/imAccounts.js
@@ +6,5 @@
>    EmptyEnumerator,
>    nsSimpleEnumerator,
>    XPCOMUtils,
> +  setTimeout,
> +  clearTimeout,

This file also uses executeSoon.

::: mail/components/im/content/imAccounts.js
@@ +8,5 @@
>  /* globals statusSelector */
>  
>  var { Services } = ChromeUtils.import("resource:///modules/imServices.jsm", null);
>  var { fixIterator } = ChromeUtils.import("resource:///modules/iteratorUtils.jsm");
> +var { setTimeout, clearTimeout } = ChromeUtils.import("resource:///modules/imXPCOMUtils.jsm");

Was there any error related to missing these functions? Normally they are already part of the window object in that case, as this is loaded in a xul window.
Attachment #9041907 - Flags: review?(florian) → review-

Right, I think I added those since I first thought the error was from the other imAccounts.js file (quite confusing we have two of same name). Apparently it's not needed.

Attached patch bug1525695_irc_refs.patch (obsolete) — Splinter Review
Attachment #9041907 - Attachment is obsolete: true
Attachment #9042020 - Flags: review?(florian)
Comment on attachment 9042020 [details] [diff] [review]
bug1525695_irc_refs.patch

Review of attachment 9042020 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9042020 - Flags: review?(florian) → review+

For checkin.

Attachment #9042020 - Attachment is obsolete: true
Attachment #9042105 - Flags: review+
Keywords: checkin-needed
Blocks: 1520643

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b8273f79234e
fix a bunch of missing imports in IRC and IM related code. r=florian

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 67.0
You need to log in before you can comment on or make changes to this bug.