Visual artifacts in add-on menu with webrender enabled on mac

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
5 months ago
Last month

People

(Reporter: bpitts, Assigned: jrmuizel)

Tracking

(Blocks 1 bug, {regression})

Trunk
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 wontfix, firefox67 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

5 months ago

With webrender enabled, when I click the lastpass button the menu that appears has visual artifacts (e.g. blue bars, scrambled text) that change as I mouse over different entries.

When I disable webrender, the problem goes away.

I'm running the latest nightly on OS X on a macbook pro.

Assignee

Comment 1

5 months ago

I believe this is a regression.

Assignee

Updated

5 months ago
Priority: -- → P2
Assignee

Comment 2

5 months ago

Turning off picture caching fixes the issue. Kats thinks this is probably a regression caused by bug 1524385 in combination with picture caching.

Assignee

Comment 4

5 months ago

Also this seems to only show up on Mac

Assignee

Updated

5 months ago
Priority: P2 → P3
Assignee

Updated

5 months ago
Blocks: 1524385
Assignee

Updated

5 months ago
Summary: Visual artifacts in Lastpass menu with webrender enabled → Visual artifacts in add-on menu with webrender enabled
Reporter

Comment 5

5 months ago

I can confirm enabling webrender but disabling picture caching fixes the issue for me.

Assignee

Updated

5 months ago
Summary: Visual artifacts in add-on menu with webrender enabled → Visual artifacts in add-on menu with webrender enabled on mac intel
Assignee

Comment 6

5 months ago
Assignee: nobody → jmuizelaar
Assignee

Updated

5 months ago
Attachment #9041989 - Attachment is obsolete: true
Assignee

Comment 8

5 months ago

Comment on attachment 9041990 [details]
Bug 1525740. Disable picture caching on popups

This patch doesn't work because we still end up with picture caching turned on inside the Iframe

Attachment #9041990 - Attachment is obsolete: true

Comment 9

5 months ago

The existing picture caching code in WR assumes that the tiles are being
drawn into the main framebuffer. This is true to the main content frame,
however it's not the case for all popup windows. In the case of popup
windows on mac, they have a rounded rect clip, which results in a surface
being used. This breaks some assumptions in the picture caching code.

The long term fix involves supporting picture caching on surfaces. However,
we don't want picture caching on for non-content windows anyway (due to
wasting texture memory), so for now we will simply disable picture cache
composite modes if they are being drawn on a non-root surface.

Assignee

Updated

5 months ago
Summary: Visual artifacts in add-on menu with webrender enabled on mac intel → Visual artifacts in add-on menu with webrender enabled on mac

Comment 10

5 months ago
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f526887aa3ae
Visual artifacts in add-on menu with webrender enabled on mac intel. r=jrmuizel
Assignee

Updated

5 months ago

Comment 11

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Given the comments in bug 1524385 about uplifting to 66, setting the status for 66 to affected here as well.

QA Whiteboard: [qa-67b-p2]

Updated

Last month
Regressions: 1554502
You need to log in before you can comment on or make changes to this bug.