Closed Bug 1525814 Opened 2 years ago Closed 2 years ago

Dictionary AddOn disabled when upgrading to 65.0

Categories

(Toolkit :: Add-ons Manager, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- wontfix

People

(Reporter: greenbay.graham, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Upgraded on Windows and Ubuntu to 65.0

Actual results:

This previoulsly installed add-on is marked "disabled" and can't use it for spell-checking
https://addons.mozilla.org/en-US/firefox/addon/takikupu/

Expected results:

Tried removing and re-adding but then get "Download failed. Please check your connection." from download page.
Expected to be able to re-add.

:aswan can you confirm that this is Invalid and the add-on needs to be updated?

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=da158202751e9481710c64264d5f0e9161f6eb36&tochange=0c715a8f0170fd4b19c4281c269c03f872090648

STR

  1. https://addons.mozilla.org/firefox/addon/takikupu/
  2. Right-click the "Add to Firefox" button and choose "Save Link As…" then save the file somewhere like the desktop.
  3. Open about:addons, then click Extensions on the left.
  4. Drag and drop the earlier file onto the Firefox window.

ER
[about:addons]
This site would like to install an add-on in Nightly:
takikupu
<Add> <Cancel>

AR
[about:addons]
This add-on could not be installed because it appears to be corrupt.
<OK!>

Blocks: 857456
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Add-ons Manager
Flags: needinfo?(aswan)
Keywords: regression
Product: Firefox → Toolkit

Yes, that dictionary uses the obsolete install.rdf format.
We don't appear to have documentation on the manifest.json format anywhere, I've added dev-doc-needed to bug 1410214 to get the docs updated.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aswan)
Resolution: --- → INVALID

So I just need to replace the install.rdf with a manifest.json file of this format (I found this in the Spanish dict add on). Right?

{
    "dictionaries": {
        "es-VE": "dictionaries/es_VE.dic"
    },
    "version": "1.1.18.2webext",
    "browser_specific_settings": {
        "gecko": {
            "id": "es-ve@dictionaries.addons.mozilla.org"
        }
    },
    "name": "Spanish (Venezuela) spell check dictionary",
    "manifest_version": 2
}

From a quick glance, that looks about right. Replacing the id, language code, etc. as appropriate of course.

You need to log in before you can comment on or make changes to this bug.