Mozilla browser freezes and goes comatose when browsing a particular web site

VERIFIED WORKSFORME

Status

Documentation
Help Viewer
--
critical
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Brian Vetter, Assigned: Joe Chou)

Tracking

({hang})

unspecified
Future
x86
Windows 2000

Details

(URL)

(Reporter)

Description

16 years ago
When I try to browse the site http://www.ghcs.org, Mozilla hangs and becomes
unresponsive. I have no idea why, but IE6 and NS4 work fine. It appears to be a
page created using frontpage and their java applets for hover buttons. It could
be hosing up when kicking off the Java VM, but I have not problems running any
other sites with Java.
Reporter:
Which JRE do you use ?
if 1.3.x can you please upgrade to JRE1.4 and try again ?

Comment 2

16 years ago
WFM 1.1 alpha, 2002061712 Windows 98, Sun Java 1.4.0_01.

Reporter, use the Bugzilla Helper to report bugs. What version of Mozilla are 
you using? Try upgrading Mozilla as well as your Java version, like comment 1 
said to do.
Assignee: Matti → joe.chou
Component: Browser-General → OJI
Keywords: hang
QA Contact: imajes-qa → pmac
(Reporter)

Comment 3

16 years ago
I had already moved to JRE 1.3.1_02 because of previous JRE issues in RC2 (see
release notes). I upgraded to JRE 1.4.0_01 and it got stuck in an infinite loop.
I then went and deleted the NPOJI610.dll that was laid down as part of the JRE
install and it now works (I can browse the page, not that I want to).

As to Andrews questions/comments, I did use the reporter and for the life of me,
couldn't get the version info into the fields. "other" was the only option. That
said, I'm using Mozilla 1.0 and I had JRE 1.3.1_02 installed.

If the solution is to use JRE 1.4, then I suggest the release notes get fixed.
This is a bug in JRE 1.3.x and Mozilla can't fix it...
Also this is already fixed because it works with JRE1.4

-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

16 years ago
Fine, call it fixed because it works in JRE 1.4, but reassign this as a bug in
the release notes. The release notes say that it has been tested and works in
JRE's after JRE 1.3.1_01 - that is not true.

Fix the release note.
Status: RESOLVED → UNCONFIRMED
Component: OJI → User
Product: Browser → Documentation
Resolution: WORKSFORME → ---
Target Milestone: --- → Future
Version: other → unspecified
no !
This is a special case !
JRE1.3.x works as expected on 96% of all pages.
97.5% will work with JRE1.4.X

(the numbers are random)

-> wfm
The documentaion is correct. This is a simple bug in The JRe1.3.x plugin with
this applet..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Too bad the fphover applet that causes this hang is used by lots of lazy people
who use Frontpage. I run into it way too often.

Comment 8

15 years ago
For sites with problems such as this, file an issue in Tech Evangelism.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.