[snappy][Ubuntu 16.04 GNOME][CSD] Window cannot be resized with cursor and has no shadow with Ambiance theme

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
4 months ago
3 months ago

People

(Reporter: ke5trel, Unassigned)

Tracking

(Blocks 1 bug, {regression})

66 Branch
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 unaffected, firefox66 fixed, firefox67 fixed)

Details

Reporter

Description

4 months ago

The Snap package beta 66.0b6 with Ambiance theme on Ubuntu 18.10 does not allow the window edges to be resized with the cursor, the cursor icon does not change on hover over any of the window edges and clicking and dragging does nothing. The window also doesn't have a shadow which usually comprises the resize zone. Turning on the system titlebar restores functionality.

Resizing works and shadow is rendered with the Adwaita theme (also used as fallback for Yaru).

Most likely caused by Bug 1521012.

Reporter

Comment 1

4 months ago

I can reproduce this with latest Nightly 67 on Ubuntu 16.04 (Snap build environment) with ubuntu-gnome-desktop installed and Ambiance theme. Other applications have the same problem, Ambiance theme appears to be broken on GNOME Shell in 16.04 and this is carried through in the Snap.

On Nightly 67 it does not occur with mozilla.widget.use-argb-visuals defined regardless of value.
On Beta 66.0b6 it does not occur with mozilla.widget.use-argb-visuals = false.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1c227ac918eb1ab0b702d4424603faeb836f2b1c&tochange=64d38928ff5a59fb8214a0ee2472dccd6f16705d

Regressed by Bug 1521012.

Hey Jimm, should we still be tracking this for 66?

Flags: needinfo?(jmathies)
Reporter

Updated

3 months ago
Summary: [snappy][CSD] Window cannot be resized with cursor and has no shadow with Ambiance theme → [snappy][Ubuntu 16.04 GNOME][CSD] Window cannot be resized with cursor and has no shadow with Ambiance theme
Reporter

Comment 3

3 months ago

This has been fixed on Ubuntu 16.04 with GNOME desktop by Bug 1529713.

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Depends on: 1529713
Resolution: --- → WORKSFORME

Updated

3 months ago
Flags: needinfo?(jmathies)
You need to log in before you can comment on or make changes to this bug.