[FIX]Bookmark/Tab group load focuses first tab in group regardless of 'Load links in the background' pref

RESOLVED FIXED in mozilla1.2alpha

Status

SeaMonkey
Tabbed Browser
P2
minor
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: djk, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020617
BuildID:    2002061707

I have the 'Load links in the background' preference turned on.

When I load a tabgroup, I expect it to obey this pref; load the tabs of the
group in the background.  Instead, the first tab in the group is focused.

Reproducible: Always
Steps to Reproduce:
1. Create a tabgroup
2. Set Tabbed Browsing pref 'Load links in the background' to on (checked)
3. Open the tabgroup


Actual Results:  Tabs in the group are appended to existing tabs, and the first
tab of the group is switched to.

Expected Results:  Tabs in the group are appended to existing tabs, and the
current tab is still focused.

Comment 1

16 years ago
I can reproduce this with Build 2002062208, Win XP and couldnĀ“t find a
duplicate, so marking NEW.

This bug is a consequence of the behaviour to preserve the already open tabs and
load a bookmark group in new tabs. I believe the "Load links in the background"
pref should be honored whenever links in new tabs are opened. So a more general
bug than this may make sense.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 153018 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 161466
jag: do we want to fix this, or is this going to be WONTFIXed?

Comment 4

16 years ago
I agree that this should be fixed. Caillon, do you want to take this bug?
Created attachment 95910 [details] [diff] [review]
The fix
I'd better take this since I have the patch.
Assignee: jaggernaut → caillon
Priority: -- → P2
Summary: Bookmark/Tab group load focuses first tab in group regardless of 'Load links in the background' pref → [FIX]Bookmark/Tab group load focuses first tab in group regardless of 'Load links in the background' pref
Target Milestone: --- → mozilla1.2alpha

Comment 7

16 years ago
Comment on attachment 95910 [details] [diff] [review]
The fix

there's a pref or prefs global variable that you could reuse :-)

sr=jag if you use that.
Attachment #95910 - Flags: superreview+
Comment on attachment 95910 [details] [diff] [review]
The fix

r=sicking
Attachment #95910 - Flags: review+
Landed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: sairuh → claudius

Comment 10

13 years ago
This is broken again. Re-opening.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040924

Prog.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Blocks: 135915

Comment 11

13 years ago
This bug was fixed two years ago.  No doubt, if it is broken, the reasons behind
it being so are now radically different than they were before.

I'm going to mark this FIXED again.  Please create a new case and refer back to
this one.  But one so old should stay closed...
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → FIXED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.