Pref Search in PBM to ON by default in 66 Release

RESOLVED FIXED in Firefox 66

Status

()

defect
P1
normal
RESOLVED FIXED
5 months ago
18 days ago

People

(Reporter: rrosario, Assigned: rrosario)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66+ fixed, firefox67 fixed)

Details

Attachments

(1 attachment)

This basically will revert Bug Bug 1521961. We now want PBM with Search ON by default \o/

MozReview-Commit-ID: 9Ocns8ig19H

Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5a7505f349c9
Pref Search in PBM to ON by default in 66 Release r=nanj
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Comment on attachment 9042518 [details]
Bug 1526366 - Pref Search in PBM to ON by default in 66 Release

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

By default, there would be no search in about:privatebrowsing in Release 66.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

Yes

If yes, steps to reproduce

Go to about:privatebrowsing in Private Browsing mode and verify the search box is present.

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

This is just a pref change. The feature is already enabled by default in beta and nightly.

String changes made/needed

Attachment #9042518 - Flags: approval-mozilla-beta?

The feature description in Trello only says this is not ready to be turned on by default and it might roll out gradually on 66 release. So, maybe that's changed because of a positive report from QA? I haven't seen the sign off.

Flags: needinfo?(rrosario)
Flags: needinfo?(mpopova)
Flags: needinfo?(mconnor)

From mconnor this morning, the plan is to have this off by default and control the rollout from Normandy.

Flags: needinfo?(mpopova)
Flags: needinfo?(mconnor)
Attachment #9042518 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
Flags: needinfo?(rrosario)
Blocks: 1501747

This feature is not yet signed off because we're waiting to get closer to Release 66 to start our test runs. The closer we are to the targeted release the better it is to assure that no issues appear right before release.
If the plan is for this feature to be signed off ASAP we can do that, otherwise, we're targeting the 25th of Feb - 8th of March to start testing and send the sign off. Initial testing in Nightly and Beta looked good.

Per comment 6, we aren't uplifting this.

[Tracking Requested - why for this release]:

OK. Sorry for all the see-saw on this feature, :lizzard and :cmuresan!

Liz, I'm not sure how to set the flags on the patch to re-request uplift. Should I attach the patch again? Ciprian, I guess we go back to the original QA plan you suggested in comment #7. Is that OK?

We want to pref this feature on by default in 66 release and will run a hold-back experiment to measure the difference (https://experimenter.services.mozilla.com/experiments/search-in-private-browsing-new-tab-impact-study/).

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(lhenry)
Flags: needinfo?(ciprian.muresan)

Tim - We can just use the existing patch; I can reset the flags. I'll ask you for a link to the plan or discussion of it in the related Trello card.

Flags: needinfo?(lhenry)
Attachment #9042518 - Flags: approval-mozilla-beta- → approval-mozilla-beta+

I was asked to look at this feature from the privacy perspective and do a review to ensure that there are no blockers for shipping it. I looked at the code behind it as well as how it behaves through testing locally and couldn't find any problems.

From my perspective I don't see any reason to withhold this from shipping in 66. Thanks to everyone who helped make this happen!

Removing my needinfo as QA has signed off on both the feature and the experiment (both were GREEN).

Flags: needinfo?(ciprian.muresan)
Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → FIXED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.