Closed Bug 1526376 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 15151 - [LayoutNG] Fixed elements inside split inlines triggered DCHECK

Categories

(Core :: CSS Parsing and Computation, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 15151 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/15151
Details from upstream follow.

Aleks Totic <atotic@chromium.org> wrote:

[LayoutNG] Fixed elements inside split inlines triggered DCHECK

The bug was that position:fixed elements were not getting laid out.
It was caused by split inlines containing block fix.

I've modified an existing testcase that we used to test split
inlines to also test fixed.

Bug: 923268
Change-Id: Ic1fe1bbdf1ffc2dfe80e4dbe5c03065be05c082c
Reviewed-on: https://chromium-review.googlesource.com/c/1445393
Commit-Queue: Aleks Totic \<atotic@chromium.org>
Reviewed-by: Ian Kilpatrick \<ikilpatrick@chromium.org>
Cr-Commit-Position: refs/heads/master@{#627663}

Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 1 tests and 2 subtests
OK     : 1
PASS   : 1
FAIL   : 1

New tests that have failures or other problems:
/css/CSS2/abspos/abspos-in-block-in-inline-in-relpos-inline.html
    position:absolute should be sized by the right ancestor: FAIL
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5085624b6a31
[wpt PR 15151] - [LayoutNG] Fixed elements inside split inlines triggered DCHECK, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/8452d9d7634b
[wpt PR 15151] - Update wpt metadata, a=testonly
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.