Options/preferences don't apply instantly in Thunderbird Daily

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: nONoNonO, Assigned: Paenglab)

Tracking

({regression})

Thunderbird 67.0
Unspecified
Windows

Thunderbird Tracking Flags

(thunderbird66 fixed, thunderbird67 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

3 months ago

Thunderbird Daily has in-content preferences, but at the moment they don't apply (at least not in Windows).

STR:

  1. Go to Tools > Options and change a setting that should apply instantly, e.g. the location of the start page on the General pane, or the way you forward messages on the Composition pane, General tab;
  2. Invoke the function you changed in step 1 (press Alt-Home in 3-pane view or press Ctrl+L to forward a message);
  3. See that the original setting is invoked (old start page, message still attached instead of included, etc)

(This is probably caused by the removal of the binding, but I don't have that bug number at hand to put in the dependencies.)

Reporter

Comment 1

3 months ago

Forgot to add some info/background: with in-content prefs there's no more OK/Cancel button, but the changed should apply instantly. The pref browser.preferences.instantApply used to take care of this, but with mail.preferences.inContent default (and not as an option anymore) there's no way to make preferences apply at the moment

Assignee

Comment 2

3 months ago

The prefs in tab always set the instantApply to true, see https://hg.mozilla.org/comm-central/diff/1f1658927d2d/mail/components/preferences/aboutPreferences.xml#l1.95. Now that we have only the in-content prefs only, we should set it on true on Windows too.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9042647 - Flags: review?(jorgk)

Comment 3

3 months ago

Hmm, I can't reproduce the problem in the first place.

If I switch to inline/as attachment or change the start page URL, then invoke the function, the new value is used, after switching back to the 3pane of course.

browser.preferences.instantApply is already true, even if I switch it to false, it's set to true when I check the next time.

I don't think the patch fixes anything.

Assignee

Comment 4

3 months ago

Also if it doesn't fix the issue that I'm not seeing, we should set the pref to true as default on Windows as it is set to true anyway. Then it reflects the real state.

Reporter

Comment 6

3 months ago

I think for me it will fixes it after all. The setting looks user set, but it really isn't or is, but maybe too late:
When I toggle it to it's default state false and restart Daily, it looks set to true again.
When I toggled it to false and then to true again and retsarted Daily, I don't think it got stored in my prefs.js.
When I added it manually to my prefs.js as set to true, the settings do apply again:
user_pref("browser.preferences.instantApply", true);

Assignee

Comment 7

3 months ago

FF doesn't use this pref in the prefs. In the prefs it's also always true. I know where is a bug around to remove this pref (bug 1325637).

Assignee

Comment 8

3 months ago

Removed a #ifdef too much.

Attachment #9042647 - Attachment is obsolete: true
Attachment #9042647 - Flags: review?(jorgk)
Attachment #9042739 - Flags: review?(jorgk)

Updated

3 months ago
Summary: Add-on options don't apply in Thunderbird Daily → Options/preferences don't apply instantly in Thunderbird Daily

Comment 9

3 months ago

I could not reproduce it on Linux e.g. with the start page.

But TB does use the instanApply pref in a few places, like https://searchfox.org/comm-central/source/mail/components/preferences/subdialogs.js#53 or https://searchfox.org/comm-central/source/mail/base/content/mailCore.js#487

Comment 10

3 months ago
Comment on attachment 9042739 [details] [diff] [review]
1526418-set-instantApply-true.patch

OK, I reproduced the problem now.
Attachment #9042739 - Flags: review?(jorgk) → review+
Assignee

Updated

3 months ago
Keywords: checkin-needed

Comment 11

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0b73fc8ae5e9
Set browser.preferences.instantApply to true on all platforms. r=jorgk

Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

3 months ago
Target Milestone: --- → Thunderbird 67.0

Updated

3 months ago
Attachment #9042739 - Flags: approval-comm-beta+
Keywords: regression

Updated

3 months ago
Duplicate of this bug: 1528275
You need to log in before you can comment on or make changes to this bug.