Closed Bug 1526430 Opened 2 years ago Closed 2 years ago

windows/aarch64 - app update tests fail due to invalid mar files

Categories

(Toolkit :: Application Update, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1526109

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: egao [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=226675668&repo=try

https://queue.taskcluster.net/v1/task/KTsONR17T9Sdo_lB4qrkLA/runs/0/artifacts/public/logs/live_backing.log

Observed during win10/aarch64 run.

One issue logged to cover all the failures. There are approximately 40 unexpected failures in total, all seem unique.

03:43:49 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | The panel ID should equal apply - "apply" == "apply" -
03:43:49 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | There should be an active update -
03:43:49 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | The active update state should equal pending -
03:43:49 INFO - TEST-PASS | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | The button should be enabled - true == true -
03:43:49 INFO - Buffered messages finished
03:43:49 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | A promise chain failed to handle a rejection: is is not defined - stack: aboutDialogOnLoad@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:534:11
03:43:49 INFO - EventListener.handleEvent*onOpenWindow@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:539:9
03:43:49 INFO - openAboutDialog@chrome://browser/content/utilityOverlay.js:810:3
03:43:49 INFO - waitForAboutDialog/<@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:545:5
03:43:49 INFO - waitForAboutDialog@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:525:10
03:43:49 INFO - runAboutDialogUpdateTest/<@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:665:25
03:43:49 INFO - async*runAboutDialogUpdateTest@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:622:17
03:43:49 INFO - aboutDialog_backgroundCheck_downloaded_staged@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/browser_aboutDialog_bc_downloaded_staged.js:18:9
03:43:49 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1106:34
03:43:49 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1097:16
03:43:49 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:995:9
03:43:49 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
03:43:49 INFO - Rejection date: Thu Feb 07 2019 03:43:48 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
03:43:49 INFO - Stack trace:
03:43:49 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
03:43:49 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1130
03:43:49 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1097
03:43:49 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
03:43:49 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
03:43:49 INFO - Leaving test bound aboutPrefs_backgroundCheck_downloaded
03:43:49 INFO - GECKO(5268) | MEMORY STAT | vsize 5823MB | vsizeMaxContiguous 67845102MB | residentFast 234MB | heapAllocated 92MB
03:43:49 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | took 1561ms
03:43:49 INFO - checking window state
03:43:49 INFO - Not taking screenshot here: see the one that was previously logged
03:43:49 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | Found an unexpected Browser:About at the end of test run -
03:43:49 INFO - GECKO(5268) | must wait for focusx

Common thread of failures appear to be the timing out of tests; each failures has: `timed out after 50 tries.`

Most likely related to bug 1526109

Depends on: 1526109
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1526109
Summary: windows/aarch64 - toolkit/mozapps/update/tests/browser/browser_aboutPrefs_bc_downloaded.js | multiple failures in browser_aboutPrefs_* → windows/aarch64 - app update tests fail due to invalid mar files
You need to log in before you can comment on or make changes to this bug.