[wpt-sync] Sync PR 15273 - Revert "Link element events should be able to fire more than once"

RESOLVED FIXED in Firefox 67

Status

enhancement
P4
normal
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: wptsync, Unassigned)

Tracking

unspecified
mozilla67
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

(Whiteboard: [wptsync downstream], )

Assignee

Description

5 months ago

Sync web-platform-tests PR 15273 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/15273
Details from upstream follow.

Dominic Farolino <domfarolino@gmail.com> wrote:

Revert "Link element events should be able to fire more than once"

This reverts commit 66236c640db16d71a5cd3f3e59638fb323d5f542.

Reason for revert: Bad and unexpected performance regressions were
introduced with this change. It is possible to incur an infinite loop
of loading a \<link> and firing the load event, if the onload function
tampers with the rel attribute, as is sometimes done with preload links.
This may prevent a window's load event from ever being fired. Mitigating
problems like this needs to more looking into before this change can land
apparently.

Performance regression bugs: https://crbug.com/927427, https://crbug.com/928796, https://crbug.com/929153, https://crbug.com/929265. The original bug (https://crbug.com/922618) has been re-opened to track future work for this.

Original change's description:

Link element events should be able to fire more than once

As per spec https://html.spec.whatwg.org/multipage/links.html#link-type-stylesheet,
the \<link> element can have its load and error events fire multiple times,
per resource it loads.

Bug: 922618
Change-Id: Ifc9ade076e119d5cf9f4eaf656c6ea7c1deb0ba9
Reviewed-on: https://chromium-review.googlesource.com/c/1423601
Reviewed-by: Kouhei Ueno \<kouhei@chromium.org>
Reviewed-by: Yutaka Hirano \<yhirano@chromium.org>
Commit-Queue: Dominic Farolino \<domfarolino@gmail.com>
Cr-Commit-Position: refs/heads/master@{#628010}

TBR=yhirano@chromium.org,kouhei@chromium.org,domfarolino@gmail.com

Not skipping CQ checks because original CL landed > 1 day ago.

Bug: 922618
Change-Id: I0affe5a242bf472743d11a4905a630da7895cfca
Reviewed-on: https://chromium-review.googlesource.com/c/1457745
Reviewed-by: Yutaka Hirano \<yhirano@chromium.org>
Reviewed-by: Dominic Farolino \<domfarolino@gmail.com>
Commit-Queue: Dominic Farolino \<domfarolino@gmail.com>
Cr-Commit-Position: refs/heads/master@{#629956}

Assignee

Updated

5 months ago
Whiteboard: [wptsync downstream] → [wptsync downstream error]
Assignee

Comment 1

5 months ago
PR 15273 applied with additional changes from upstream: 8c2f92077bd45be902b98018e62676f041a6a816
Assignee

Updated

5 months ago
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Assignee

Comment 3

5 months ago
The PR was not expected to affect any tests, but the try push wasn't a success. Check the try results for infrastructure issues
Assignee

Comment 4

5 months ago
The PR was not expected to affect any tests, but the try push wasn't a success. Check the try results for infrastructure issues
Assignee

Comment 5

4 months ago
Result changes from PR not available.

Comment 6

4 months ago
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/963cd1e41204
[wpt PR 15273] - Revert "Link element events should be able to fire more than once", a=testonly

Comment 7

4 months ago
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac6c127ae409
[wpt PR 15273] - Revert "Link element events should be able to fire more than once", a=testonly

Comment 8

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.