Focus issue with onfocus of readonly textarea

VERIFIED WORKSFORME

Status

()

Core
Event Handling
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mkaply, Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
See testcase.

When you use the onfocus of a readonly to set focus to another entryfield, 
although that entryfield gets visual focus, you can't type until you click on 
it.

Comment 1

16 years ago
WORKSFORME moz 2002092308 / win98
reporter, please retest with a newer build

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 2

15 years ago
I don't know what to think. The testcase at the provided URL works with Firebird
0.7 build 20031007. 
But does not work with Mozilla 1.5 build 20031007: the focus stays on the
readonly input and is not transferred to box3.
XP Pro SP1 here.

Comment 3

15 years ago
I tried the testcase with Mozilla 1.7alpha build 2004021508 and with Firefox 0.8
build 20040206 (rv 1.6). I clicked on first input textbox, pressed tab, got
focus into the 3rd input textbox and I could type in it.

WORKSFORME

XP Pro SP1 here.

Comment 4

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040831

Works for me. (WinXP SP2)

Comment 5

14 years ago
I get the expected results at the testpage at provided URL. Mozilla 1.8a3 build
2004083008 under XP Pro SP2 here.

Resolving as WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 6

14 years ago
Confirmed works as expected, tested on OS X with:

Firefox 0.9.3

Mozilla 1.8.3a 20040830008
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.