Closed Bug 1526650 Opened 8 months ago Closed 7 months ago

Marionette links in documentation are broken

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: dhyey35, Assigned: dhyey35)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36

Steps to reproduce:

Some of the links mentioned in https://firefox-source-docs.mozilla.org/testing/marionette/marionette/Intro.html#using-marionette are broken.

Specifically :
All links on https://marionette-client.readthedocs.io and the .md links

The ./PythonTests.md and other 2 .md links just need to be changed to .html but I have no idea where other links should point to.

I would like to submit a patch for this, I have figured out fixes for 3rd, 4th and 7th links in Intro.md file. Can you please let me know the links for 1st and 2nd. Also I think the 6th one should be updated.

Links as in Intro.md:

[1] http://marionette-client.readthedocs.io/en/latest/
[2] http://marionette-client.readthedocs.io/en/latest/interactive.html
[3] ./PythonTests.md
[4] ./Debugging.md
[5] https://developer.mozilla.org/en-US/docs/Marionette/Builds
[6] https://github.com/mozilla-b2g/marionette_js_client
[7] ./Protocol.md

Flags: needinfo?(hskupin)

(In reply to dhyey35 from comment #1)

I would like to submit a patch for this, I have figured out fixes
for 3rd, 4th and 7th links in Intro.md file. Can you please let
me know the links for 1st and 2nd. Also I think the 6th one should
be updated.

They should point to https://firefox-source-docs.mozilla.org/python/marionette_driver.html,
so ../../marionette_driver.html.

Flags: needinfo?(hskupin)

I have submitted a patch, but still have a few doubts:

  1. I have kept the links as ../../../python/marionette_driver.html as I think ../../marionette_driver.html will not work because Intro.html is inside /testing while new link is inside /python. Please let me know if I was wrong.

  2. I have kept 1st and 2nd links same. I wasn't sure what should be replacement for interactive.html

  3. Should we update https://github.com/mozilla-b2g/marionette-js-client (6th link) as that page says development has moved to https://github.com/mozilla-b2g/gaia/tree/master/tests/jsmarionette ( but this new page doesn't have a readme so I am not sure it would be helpful to new devs ) ?

Flags: needinfo?(ato)

(In reply to dhyey35 from comment #4)

  1. I have kept the links as
    ../../../python/marionette_driver.html as I think
    ../../marionette_driver.html will not work because Intro.html
    is inside /testing while new link is inside /python. Please
    let me know if I was wrong.

I’ve commented on this in the review.

  1. I have kept 1st and 2nd links same. I wasn't sure what should
    be replacement for interactive.html

This documentation should ideally be rewritten to avoid linking to
that.

  1. Should we update
    https://github.com/mozilla-b2g/marionette-js-client
    (6th link) as that page says development has moved to
    https://github.com/mozilla-b2g/gaia/tree/master/tests/jsmarionette
    ( but this new page doesn't have a readme so I am not sure it
    would be helpful to new devs ) ?

marionette-js-client and B2G is also deprecated and should be
removed. I don’t expect you to do that as part of fixing the links
however.

Flags: needinfo?(ato)
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e146e5153374
Fix broken links in Marionette Intro docs r=ato
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Thank you for fixing the documentation!

Assignee: nobody → dhyey35
You need to log in before you can comment on or make changes to this bug.