Closed Bug 1526662 Opened 4 years ago Closed 4 years ago

Feature Request - Reading mode which highlights a line at a time

Categories

(Toolkit :: Reader Mode, enhancement)

65 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: weddi.eddy, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

Loaded webpage (any webpage) with lots of black text on a white page. I started to read through the text.

Actual results:

While reading, I kept losing my spot. I would have to go through previous paragraphs to determine if I read that section or not.

Expected results:

If I switch on a new 'reading mode', I can click on a word in the text of an element and it will highlight the entire horizontal line of text displayed on my screen. Using the down or up arrow on my keyboard, I can move to the next or previous horizontal line so I know which line I need to read next and never lose my spot.

It may be a suitable workaround to

  1. Press F7 to toggle caret browsing.
  2. Press Shift + arrow keys to select a line of text.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Reader Mode
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
See Also: → 1331941

Thanks for the report. Unfortunately, like bug 1331941, I don't think there is sufficient interest to justify the complexity of implementing this feature. Ideally, it should be possible to implement support using a webextension. Using the builtin reader mode as-is for that is currently not possible because of bug 1371786 not having been fixed, which is unlikely to happen until bug 1204818 is fixed. In the meantime, it would be possible to provide functionality like this using a webextension that doesn't rely on the builtin reader mode, and that could potentially work on other web pages (not just reader mode).

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.