Closed Bug 1526759 Opened 3 years ago Closed 3 years ago

Intermittent /resource-timing/resource-timing-level1.sub.html | 'iframe: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'. - assert_greater_than_equal: 'responseStart' must be 250ms later than 'requestStart'. expected a number

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1527172

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, regression)

#[markdown(off)]
Filed by: rmaries [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=227479077&repo=mozilla-central

https://queue.taskcluster.net/v1/task/avW7G0cQQFWzqFnJoZ90cQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-02-10T10:42:27.314Z] 10:42:27 INFO - TEST-START | /resource-timing/resource-timing-level1.sub.html
[task 2019-02-10T10:42:27.331Z] 10:42:27 INFO - Closing window 82
[task 2019-02-10T10:42:56.743Z] 10:42:56 INFO -
[task 2019-02-10T10:42:56.743Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | No timeline entry for about:blank
[task 2019-02-10T10:42:56.743Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'iframe (Populate cache): The initial request populates the cache (if appropriate).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'iframe (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'xmlhttprequest (Populate cache): The initial request populates the cache (if appropriate).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'xmlhttprequest (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'script (Populate cache): The initial request populates the cache (if appropriate).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'script (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link (Populate cache): The initial request populates the cache (if appropriate).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-PASS | /resource-timing/resource-timing-level1.sub.html | 'link (Potentially Cached): Immediately fetch the same URL, exercising the cache hit path (if any).
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - TEST-UNEXPECTED-FAIL | /resource-timing/resource-timing-level1.sub.html | 'iframe: 250ms delay before 'responseStart', another 250ms delay before 'responseEnd'. - assert_greater_than_equal: 'responseStart' must be 250ms later than 'requestStart'. expected a number greater than or equal to 8170 but got 8160
[task 2019-02-10T10:42:56.744Z] 10:42:56 INFO - test/<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:135:29
[task 2019-02-10T10:42:56.745Z] 10:42:56 INFO - createOnloadCallbackFn/</<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:478:29
[task 2019-02-10T10:42:56.745Z] 10:42:56 INFO - assertInvariants/<@http://web-platform.test:8000/resource-timing/resource-timing-level1.js:309:25
[task 2019-02-10T10:42:56.745Z] 10:42:56 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1566:20
[task 2019-02-10T10:42:56.745Z] 10:42:56 INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1590:20
[task 2019-02-10T10:42:56.746Z] 10:42:56 INFO - Test.prototype.step_timeout/<@http://web-platform.test:8000/resources/testharness.js:1624:20
[task 2019-02-10T10:42:56.746Z] 10:42:56 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1566:20
[task 2019-02-10T10:42:56.746Z] 10:42:56 INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1590:20
[task 2019-02-10T10:42:56.746Z] 10:42:56 INFO -

I think someone from the DOM team needs to look at the test and figure out what's going on to make it so unstable.

Flags: needinfo?(james) → needinfo?(amarchesini)
Duplicate of this bug: 1526761
Component: DOM → DOM: Core & HTML
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1527172
Flags: needinfo?(amarchesini)
You need to log in before you can comment on or make changes to this bug.