Closed Bug 1526780 Opened 3 years ago Closed 3 years ago

Crash in [@ mozilla::QueryProgramInfo]

Categories

(Core :: Canvas: WebGL, defect)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1525857

People

(Reporter: jseward, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-b09c2523-4123-42f7-b899-32b000190209.

This was seen in three different installations in the Windows nightly
20190207094841.

Top 10 frames of crashing thread:

0 xul.dll static class RefPtr<const mozilla::webgl::LinkedProgramInfo> mozilla::QueryProgramInfo dom/canvas/WebGLProgram.cpp:477
1 xul.dll void mozilla::WebGLProgram::LinkAndUpdate dom/canvas/WebGLProgram.cpp:1516
2 xul.dll mozilla::WebGLProgram::LinkProgram dom/canvas/WebGLProgram.cpp:1226
3 xul.dll mozilla::WebGLContext::LinkProgram dom/canvas/WebGLContextGL.cpp:980
4 xul.dll static bool mozilla::dom::WebGLRenderingContext_Binding::linkProgram dom/bindings/WebGLRenderingContextBinding.cpp:18000
5 xul.dll mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy, mozilla::dom::binding_detail::ThrowExceptions> dom/bindings/BindingUtils.cpp:3138
6 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:534
7 xul.dll static bool InternalCall js/src/vm/Interpreter.cpp:589
8 xul.dll static bool Interpret js/src/vm/Interpreter.cpp:3069
9 xul.dll js::RunScript js/src/vm/Interpreter.cpp:422

Flags: needinfo?(lsalzman)
Component: DOM → Canvas: WebGL

This appears to be a dupe of Bug 1525857.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525857

Also clearing ni since Jeff is working on the issue in the other bug.

Flags: needinfo?(lsalzman)
You need to log in before you can comment on or make changes to this bug.