If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Moving messages with threading only moves the first message in each thread

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
enhancement
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Ian Burrell, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Enter threading mode
Select multiple collapsed threads
Move messages to another folder
Only the first message in each thread is moved
The other messages in remain in the original folder

The expected behaviour is that the entire collapsed thread is moved to the other
folder.

Comment 1

16 years ago
It only moves the displayed message, it is not implemented to move the replies
which are not shown.

If you want to move the thread, select the spool/thread icon in the thread
column to the left of the message and it will select the entire thread, then
move it.

I believe we may also have an old existing request about this.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: olgam → laurel

Updated

14 years ago
Blocks: 236849

Comment 2

13 years ago
dup of bug 125501 -> bug 181446?
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 3

12 years ago
(In reply to comment #1)
> It only moves the displayed message, it is not implemented to move the replies
> which are not shown.
> 
> If you want to move the thread, select the spool/thread icon in the thread
> column to the left of the message and it will select the entire thread, then
> move it.

Selecting the "speech bubble" does indeed work, but has side effects: it uncollapses the thread, which is annoying if you want to move multiple threads. Collapsing the thread again using \ changes the selection: now again only the first message is selected.

Moreover, uncollapsing a thread, selecting one message inside (not the top), and then collapsing it "moves" the selection to the top (as can be seen by uncollapsing the thread as well.

In the case of collapsed threads, it really looks as if selection is tied to display: if a message is not shown, it cannot be selected.

However, that reasoning does not apply to other situations where selected messages are not shown. For instance, it does not apply to scrolling. For example, if I make my message header-pane so small that not the entire list fits, then select first message, and then Ctrl-select last, so that both are selected but only one visible, moving the set does indeed move both even though they are never displayed at once. I think that this (scrolling) is actually the correct behavior. Selection should be a logical concept, not a purely optical one. It would be nice if the same behavior was applied to collapsed threads as well, at least as an option.

Comment 4

11 years ago
I agree, this should be at least preference. Because from GUI point of view it is more intuitive (and more common in other applications) that the whole thread would be moved.

Updated

11 years ago
Component: MailNews: Main Mail Window → MailNews: Backend
OS: Windows 2000 → All
Product: Mozilla Application Suite → Core
Hardware: PC → All

Updated

11 years ago
Assignee: mail → nobody
QA Contact: laurel → backend
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 5

8 years ago
Works now on 3.0beta3
(In reply to comment #5)
> Works now on 3.0beta3

Thanks Alain.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 7

6 years ago
This has evidently been re-introduced again in version 9.
You need to log in before you can comment on or make changes to this bug.