Closed Bug 1527264 Opened 8 months ago Closed 8 months ago

[RTL] The search engine logo is briefly displayed in the left part of the in-content "Search Bar" when it is clicked

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 67
Iteration:
67.2 - Feb 11 - 24
Tracking Status
firefox65 --- unaffected
firefox66 + verified
firefox67 --- verified

People

(Reporter: mcoman, Assigned: rrosario)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox 66 and above

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have a Firefox AR locale build installed.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Open a new "Private Window".
  3. Click inside the in-content "Search Bar" and observe the behavior.

[Expected result]:

  • The "Search Bar is focused and the text caret is displayed.

[Actual result]:

  • Also, the search engine logo is briefly displayed in the left part of the "Search Bar".

[Notes]:

  • This issue is reproducible regardless of the default search engine.
  • Attached a screen recording of the issue.

[Tracking Requested - why for this release]:

It's a tiny CSS fix for RTL users.

Assignee: nobody → rrosario
Iteration: --- → 67.2 - Feb 11 - 24
Priority: -- → P1
Pushed by rrosario@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a69e1fea9be
[RTL] The search engine logo is briefly displayed in the left part of the in-content "Search Bar" when it is clicked r=andreio
Blocks: 1501747

Can you request uplift? Thanks! Looks straightforward...

Flags: qe-verify+
Flags: needinfo?(rrosario)

Comment on attachment 9043237 [details]
Bug 1527264 - [RTL] The search engine logo is briefly displayed in the left part of the in-content "Search Bar" when it is clicked

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

RTL users will see the logo move when clicking on the search bar.

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

See Comment 0

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

It's "just" 2 lines of CSS that we were missing.

String changes made/needed

Flags: needinfo?(rrosario)
Attachment #9043237 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Whiteboard: [qa-triaged]

Comment on attachment 9043237 [details]
Bug 1527264 - [RTL] The search engine logo is briefly displayed in the left part of the in-content "Search Bar" when it is clicked

CSS fix, let's take it for beta 8.

Attachment #9043237 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that this issue is no longer reproducible with the latest Firefox Nightly AR build (67.0a1 Build ID - 20190213213409) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now the search engine logo remains displayed in the right part of the in-content "Search Bar".

Status: RESOLVED → VERIFIED

I have verified that this issue is no longer reproducible with the latest Firefox Beta (66.0b8 Build ID - 20190214195736) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the search engine logo remains displayed in the right part of the in-content "Search Bar".

Flags: qe-verify+
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.