Bootstraps say 'ERROR: Cannot find llvm-objdump' and 'Your system should be ready to build Firefox for Desktop!'

RESOLVED DUPLICATE of bug 1520920

Status

defect
RESOLVED DUPLICATE of bug 1520920
5 months ago
5 months ago

People

(Reporter: freddyb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When running mach boostrap, I was asked to install packages and it wanted to confirm that git-cinnabar is correctly setup.
It then appeard to run mach configure, which I deduce for all those checks around header files, libraries and executables.

What stands out at the very end is as follows:

0:08.53 checking for watchman... not found
0:08.53 checking for xargs... /usr/bin/xargs
0:08.53 checking for rpmbuild... not found
0:08.55 checking for llvm-objdump... not found
0:08.55 DEBUG: llvm_objdump: Trying llvm-objdump
0:08.55 ERROR: Cannot find llvm-objdump
0:08.59 *** Fix above errors and then restart with
0:08.59 "./mach build"
0:08.59 make: *** [client.mk:115: configure] Error 1
None

Your system should be ready to build Firefox for Desktop!

My guess is that bootstrap does not properly check the output from mach configure.

I think this is a dupe of bug 1520920. bootstrap is not supposed to invoke configure.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1520920
You need to log in before you can comment on or make changes to this bug.