The print preview buttons are not entirely clickable

RESOLVED DUPLICATE of bug 1525850

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1525850
2 months ago
16 days ago

People

(Reporter: emilghitta, Assigned: stransky)

Tracking

(Blocks 1 bug, {regression})

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 fix-optional, firefox67 fix-optional, firefox68 fix-optional)

Details

(Reporter)

Description

2 months ago

Affected versions

  • Firefox 66.0b7 (BuildId:20190211185957).
  • Firefox 67.0a1 (BuildId:20190212095015).

Unaffected versions

  • Firefox 65.0.1 (BuildId:20190211233335).
  • Firefox 60.5.1esr (BuildId:20190211182645).

Affected platforms

  • Ubuntu 18.04 64bit

Unffected platforms

  • Windows 10 64bit
  • macOS 10.13.6

Steps to reproduce

  1. Launch Firefox.
  2. Access the following link: https://cdn4.libris.ro/userdocspdf/589/faust.pdf
  3. Click the “Hambruger menu”.
  4. Click the “Print” option.
  5. Try to click the print preview buttons (ex. “Landscape”).

Expected result

  • The buttons are clickable.

Actual result

  • The buttons are not entirely clickable (it seems that the button looses focus on different hover positions).

Regression range

Additional notes

(Reporter)

Comment 1

2 months ago

Hi Martin,

It seems that mozregression pointed out Bug 1521012 for causing this regression.

Can you please have a look?

Thank you

Flags: needinfo?(stransky)
(Reporter)

Updated

2 months ago
Has Regression Range: --- → yes
Has STR: --- → yes
(Assignee)

Comment 2

2 months ago

yes, I'll look at it.

Assignee: nobody → stransky
Blocks: gtktitlebar
Flags: needinfo?(stransky)

Comment 3

2 months ago

The print preview mode enables the system titlebar so this the same as Bug 1525850.

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525850
(Assignee)

Comment 4

2 months ago

I'd like to fix it here.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

2 months ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

2 months ago

Looks like the mouse pointer position is wrongly calculated when system titlebar is turned on in CSD mode. I suspect the root window/offset is incorrectly calculated somehow, it also affects popup menus in print dialogs, those are shifted and the shift is scaled by mouse distance from left top corner. Doesn't happens in full screen more or with non-csd decorations.

(Assignee)

Comment 6

2 months ago

The actual regression is the switch from window manager to client side decorations here at Bug 1521012.

(Assignee)

Updated

2 months ago
Priority: -- → P2
(Assignee)

Comment 7

2 months ago

There may be something broken at X11 level, it behaves as the mShell X window has input shape mask 12 pixels high applied on the window top but there's no mask here. The shape mask applied at Bug 1521012 is not related, it can be reproduced just with CSD mode.

Comment 8

2 months ago

It does not happen with mozilla.widget.use-argb-visuals defined regardless of value.

(Assignee)

Comment 9

2 months ago

(In reply to Kestrel from comment #8)

It does not happen with mozilla.widget.use-argb-visuals defined regardless
of value.

I do see this bug with mozilla.widget.use-argb-visuals=false

Comment 10

2 months ago

I rechecked and it definitely does not happen for me with mozilla.widget.use-argb-visuals=false or true on Ubuntu 18.10 XWayland with latest Nightly and a new profile.

(Assignee)

Comment 11

2 months ago

Okay, closing as dupe of bug 1525850 after all.

Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525850
You need to log in before you can comment on or make changes to this bug.