Perma xpcshell TEST-UNEXPECTED-TIMEOUT | toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Test timed out when Gecko 67 merges to Beta on 2019-03-12

VERIFIED FIXED in Firefox 67

Status

defect
P5
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

Tracking

unspecified
mozilla67

Firefox Tracking Flags

(thunderbird_esr60 unaffected, firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

Attachments

(1 attachment)

#[markdown(off)]
Filed by: dvarga [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=227910112&repo=try

https://queue.taskcluster.net/v1/task/erAz5xmCQSOCK9hiM67veg/runs/0/artifacts/public/logs/live_backing.log

Central as Beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=a15012540c8626159e4e499f0ec73149ec4138f8

[task 2019-02-12T13:59:56.751Z] 13:59:56 INFO - TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_contentScripts_register.js
[task 2019-02-12T14:00:04.504Z] 14:00:04 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_contentScripts_register.js | took 7752ms
[task 2019-02-12T14:00:04.520Z] 14:00:04 INFO - TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js
[task 2019-02-12T14:05:04.521Z] 14:05:04 WARNING - TEST-UNEXPECTED-TIMEOUT | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Test timed out
[task 2019-02-12T14:05:04.523Z] 14:05:04 INFO - TEST-INFO took 300001ms
[task 2019-02-12T14:05:04.523Z] 14:05:04 INFO - >>>>>>>
[task 2019-02-12T14:05:04.524Z] 14:05:04 INFO - PID 17784 | [17784, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file /builds/worker/workspace/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2532
[task 2019-02-12T14:05:04.525Z] 14:05:04 INFO - PID 17784 | JavaScript strict warning: resource://testing-common/AddonTestUtils.jsm, line 278: ReferenceError: reference to undefined property "testScope"
[task 2019-02-12T14:05:04.526Z] 14:05:04 INFO - "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "testScope"" {file: "resource://testing-common/AddonTestUtils.jsm" line: 278}]"
[task 2019-02-12T14:05:04.526Z] 14:05:04 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-02-12T14:05:04.527Z] 14:05:04 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-02-12T14:05:04.527Z] 14:05:04 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-02-12T14:05:04.528Z] 14:05:04 INFO - running event loop
[task 2019-02-12T14:05:04.529Z] 14:05:04 INFO - xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Starting check_remote
[task 2019-02-12T14:05:04.529Z] 14:05:04 INFO - (xpcshell/head.js) | test check_remote pending (2)
[task 2019-02-12T14:05:04.530Z] 14:05:04 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | check_remote - [check_remote : 1] useRemoteWebExtensions matches - true == true
[task 2019-02-12T14:05:04.531Z] 14:05:04 INFO - TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | check_remote - [check_remote : 1] testing from extension process - false == false
[task 2019-02-12T14:05:04.531Z] 14:05:04 INFO - (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-02-12T14:05:04.533Z] 14:05:04 INFO - (xpcshell/head.js) | test run_next_test 1 pending (2)
[task 2019-02-12T14:05:04.534Z] 14:05:04 INFO - (xpcshell/head.js) | test check_remote finished (2)
[task 2019-02-12T14:05:04.538Z] 14:05:04 INFO - xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Starting test_apiScript_exports_simple_sync_method
[task 2019-02-12T14:05:04.547Z] 14:05:04 INFO - (xpcshell/head.js) | test test_apiScript_exports_simple_sync_method pending (2)
[task 2019-02-12T14:05:04.548Z] 14:05:04 INFO - "Extension attached"
[task 2019-02-12T14:05:04.549Z] 14:05:04 INFO - PID 17784 | ++DOCSHELL 0xe70b8000 == 1 [pid = 17784] [id = {8cc4373b-6737-46d7-8e3b-aa069285de15}]
[task 2019-02-12T14:05:04.550Z] 14:05:04 INFO - PID 17784 | ++DOMWINDOW == 1 (0xe88688d0) [pid = 17784] [serial = 1] [outer = (nil)]
[task 2019-02-12T14:05:04.551Z] 14:05:04 INFO - PID 17784 | ++DOMWINDOW == 2 (0xe6b48800) [pid = 17784] [serial = 2] [outer = 0xe88688d0]
[task 2019-02-12T14:05:04.552Z] 14:05:04 INFO - PID 17784 | [17784, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/worker/workspace/build/src/extensions/cookie/nsPermissionManager.cpp, line 2959
[task 2019-02-12T14:05:04.553Z] 14:05:04 INFO - (xpcshell/head.js) | test run_next_test 1 finished (2)

Summary: Perma xpshell TEST-UNEXPECTED-TIMEOUT | toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Test timed out when Gecko 67 merges to Beta on 2019-03-12 → Perma xpcshell TEST-UNEXPECTED-TIMEOUT | toolkit/components/extensions/test/xpcshell/test_ext_userScripts_exports.js | Test timed out when Gecko 67 merges to Beta on 2019-03-12
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Flags: needinfo?(lgreco)

The issue is fixed with the patch @comment 2 imported on today's beta-sims; https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=success%2Ctestfailed%2Cbusted%2Cexception&revision=4e5f61921ae313ef68e61a6cb8e1a1147c2ae49e&searchStr=xpc&group_state=expanded&selectedJob=228160009

Luca, please land the patch on autoland/inbound once it gets r+, or you can put the checkin-needed tag and one of the sheriffs will land it. Thank you.

Flags: needinfo?(lgreco)
Attachment #9043334 - Attachment description: Bug 1527330 - Fix test_ext_userScript_export.js failure on beta. r?robwu! → Bug 1527330 - Fix test_ext_userScript_exports.js failure on beta. r?robwu!
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/b1b031c761f5
Fix test_ext_userScript_exports.js failure on beta. r=robwu
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Flags: needinfo?(lgreco)
You need to log in before you can comment on or make changes to this bug.